ICA AROMA error for one participant


I have been running an analysis via fMRIprepe which has been working normally for my participants but for one I just recieved this error:

Node: fmriprep_wf.single_subject_16_wf.func_preproc_task_dmus_run_001_wf.ica_aroma_wf.ica_aroma
Working directory: /tmp/work/fmriprep_wf/single_subject_16_wf/func_preproc_task_dmus_run_001_wf/ica_aroma_wf/ica_aroma

Node inputs:

TR = 0.8
args = -np
compress_report = auto
denoise_type = nonaggr
dim =
environ = {}
feat_dir =
fnirt_warp_file =
in_file =
mask =
mat_file =
melodic_dir =
motion_parameters =
out_dir = out
out_report = ica_aroma_reportlet.svg
report_mask =

Traceback (most recent call last):
File “/opt/conda/lib/python3.8/site-packages/nipype/interfaces/base/core.py”, line 530, in aggregate_outputs
setattr(outputs, key, val)
File “/opt/conda/lib/python3.8/site-packages/nipype/interfaces/base/traits_extension.py”, line 330, in validate
value = super(File, self).validate(objekt, name, value, return_pathlike=True)
File “/opt/conda/lib/python3.8/site-packages/nipype/interfaces/base/traits_extension.py”, line 135, in validate
self.error(objekt, name, str(value))
File “/opt/conda/lib/python3.8/site-packages/traits/base_trait_handler.py”, line 74, in error
raise TraitError(
traits.trait_errors.TraitError: The ‘nonaggr_denoised_file’ trait of a _ICA_AROMAOutputSpecRPT instance must be a pathlike object or string representing an existing file, but a value of ‘/tmp/work/fmriprep_wf/single_subject_16_wf/func_preproc_task_dmus_run_001_wf/ica_aroma_wf/ica_aroma/out/denoised_func_data_nonaggr.nii.gz’ <class ‘str’> was specified.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/opt/conda/lib/python3.8/site-packages/nipype/pipeline/plugins/multiproc.py”, line 67, in run_node
result[“result”] = node.run(updatehash=updatehash)
File “/opt/conda/lib/python3.8/site-packages/nipype/pipeline/engine/nodes.py”, line 516, in run
result = self._run_interface(execute=True)
File “/opt/conda/lib/python3.8/site-packages/nipype/pipeline/engine/nodes.py”, line 635, in _run_interface
return self._run_command(execute)
File “/opt/conda/lib/python3.8/site-packages/nipype/pipeline/engine/nodes.py”, line 741, in _run_command
result = self._interface.run(cwd=outdir)
File “/opt/conda/lib/python3.8/site-packages/nipype/interfaces/base/core.py”, line 429, in run
runtime = self._post_run_hook(runtime)
File “/opt/conda/lib/python3.8/site-packages/niworkflows/interfaces/reportlets/segmentation.py”, line 231, in _post_run_hook
outputs = self.aggregate_outputs(runtime=runtime)
File “/opt/conda/lib/python3.8/site-packages/nipype/interfaces/base/core.py”, line 537, in aggregate_outputs
raise FileNotFoundError(msg)
FileNotFoundError: No such file or directory ‘/tmp/work/fmriprep_wf/single_subject_16_wf/func_preproc_task_dmus_run_001_wf/ica_aroma_wf/ica_aroma/out/denoised_func_data_nonaggr.nii.gz’ for output ‘nonaggr_denoised_file’ of a ICA_AROMARPT interface

I am not sure what is the cause for this error. Would anyone be able to assist?

Thanks a lot,



What version fmriprep is this?


Hi Steven,

The version is 21.0.0.



Does this error consistently happen for this subject? Have you tried deleting the cache and rerunning?

Yes so I have done that 2 times but I recieve the same error.

I am running everything via a docker with these exact settings:

  • /opt/conda/bin/fmriprep /data /out participant --participant-label 16 --fs-no-reconall --nthreads 8 --omp-nthreads 4 --mem-mb 32000 --low-mem --dummy-scans 6 --use-aroma

and in the last run there was an issue with the ICA arroma completing of the first run but not with the second run.