ICA-AROMA error -ram related issue?

Hello I am running an fMRIpreprocessing analysis with the following settings:

  • fMRIPrep version: 20.2.6
  • fMRIPrep command: /usr/local/miniconda/bin/fmriprep /data /out participant --participant-label 01 --use-aroma

I recieve though the following errors when I run the analysis (stoping at the ICA AROMA step):

File: /out/fmriprep/sub-01/log/20211208-121741_0930c306-79fd-427e-be59-4657da15ff9b/crash-20211209-222706-root-ica_aroma-a12b5698-58e7-4d40-bd6e-3e54632a1f22.txt
Working Directory: /tmp/work/fmriprep_wf/single_subject_01_wf/func_preproc_task_dmus_run_001_wf/ica_aroma_wf/ica_aroma
TR: 0.8
args: -np
compress_report: auto
denoise_type: nonaggr
environ: {}
out_dir: out
out_report: ica_aroma_reportlet.svg
Traceback (most recent call last):
File “/usr/local/miniconda/lib/python3.7/site-packages/nipype/pipeline/plugins/multiproc.py”, line 67, in run_node
result[“result”] = node.run(updatehash=updatehash)
File “/usr/local/miniconda/lib/python3.7/site-packages/nipype/pipeline/engine/nodes.py”, line 521, in run
result = self._run_interface(execute=True)
File “/usr/local/miniconda/lib/python3.7/site-packages/nipype/pipeline/engine/nodes.py”, line 639, in _run_interface
return self._run_command(execute)
File “/usr/local/miniconda/lib/python3.7/site-packages/nipype/pipeline/engine/nodes.py”, line 751, in _run_command
f"Exception raised while executing Node {self.name}.\n\n{result.runtime.traceback}"
nipype.pipeline.engine.nodes.NodeExecutionError: Exception raised while executing Node ica_aroma.

Traceback (most recent call last):
File “/usr/local/miniconda/lib/python3.7/site-packages/nipype/interfaces/base/core.py”, line 454, in aggregate_outputs
setattr(outputs, key, val)
File “/usr/local/miniconda/lib/python3.7/site-packages/nipype/interfaces/base/traits_extension.py”, line 330, in validate
value = super(File, self).validate(objekt, name, value, return_pathlike=True)
File “/usr/local/miniconda/lib/python3.7/site-packages/nipype/interfaces/base/traits_extension.py”, line 135, in validate
self.error(objekt, name, str(value))
File “/usr/local/miniconda/lib/python3.7/site-packages/traits/trait_handlers.py”, line 172, in error
value )
traits.trait_errors.TraitError: The ‘nonaggr_denoised_file’ trait of a _ICA_AROMAOutputSpecRPT instance must be a pathlike object or string representing an existing file, but a value of ‘/tmp/work/fmriprep_wf/single_subject_01_wf/func_preproc_task_dmus_run_001_wf/ica_aroma_wf/ica_aroma/out/denoised_func_data_nonaggr.nii.gz’ was specified.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/local/miniconda/lib/python3.7/site-packages/nipype/interfaces/base/core.py”, line 399, in run
runtime = self._post_run_hook(runtime)
File “/usr/local/miniconda/lib/python3.7/site-packages/niworkflows/interfaces/segmentation.py”, line 211, in _post_run_hook
outputs = self.aggregate_outputs(runtime=runtime)
File “/usr/local/miniconda/lib/python3.7/site-packages/nipype/interfaces/base/core.py”, line 461, in aggregate_outputs
raise FileNotFoundError(msg)
FileNotFoundError: No such file or directory ‘/tmp/work/fmriprep_wf/single_subject_01_wf/func_preproc_task_dmus_run_001_wf/ica_aroma_wf/ica_aroma/out/denoised_func_data_nonaggr.nii.gz’ for output ‘nonaggr_denoised_file’ of a ICA_AROMARPT interface

I also recieve a warining message in the beggining of the analysis that is saying that the some nodes exceed the total amount of memory available.

Would this error be related only to the memory asloted to the analysis? In the HTML file I can see there is visualisation of some ICA components but I cannot see any related output on the command window.

Thank you in advance for all you help.


Hi George,

This looks similar to my issue, you may have a look here: fMRIprep Aroma error

and also here: https://github.com/nipreps/fmriprep/issues/2622

1 Like

Thanks a lot, yes we seem to share the same problem. Have you tried allocating different ram to the analysis (in case that is the reason for the issue)? Would you happen to have big data size? (mine is 2.5 GB per session in the functional scans).

Hmm, my functional scan is about 90 minutes long, one session. Data size is of the (compressed) nifti is 516 mb. I have 40gb of ram available (of which I allocate 35gb).

You can also try going to version 21.0.0rc2, in the github thread linked above the error did not occur after updating.