Intel Mac - Freeview GUI Crashes on Open

Summary of what happened:

Freeview crashing on open and/or surface loading on Intel Mac Ventura 13.4.1

This week, I had about 10 surfaces loaded simultaneously with 3/4 labels on each. After finishing, I tried to remove the surfaces by highlight the surface in the upper left menu, and clicking the red X gui button to remove surfaces (this button has worked without issue for a while since getting Freesurfer 7.1.1). I clicked the button in rapid succession, and after the third or fourth surface deleted without issue, Freeview crashed and the error message was a Segmentation fault (detailed below).

I had seen this error before, and previously a restart had solved the problem. On restart with the freeview command, I received the same error.

Following this, I uninstalled Freeview, and redownloaded Freeview for Mac according to the instructions here. After reopening Freeview, the GUI opened! — but, whenever I tried to load a surface or a volume, my screen would flash red and Freeview would crash with a similar error report to before. After restarting from there, Freeview would no longer open and the error message continued to be the same.

The last thing I tried was referencing my original .tar file for the Freesurfer suite. I was curious if the dev version of Freeview was causing issues on my machine, and thought reverting to the version which had worked in the past might solve the problem. Using the version of Freeview in this older .tar, I still receive the same error.

Next I

Command used (and if a helper script was used, a link to the helper script or the command generated):

freeview from the command line. Clicking on in Finder creates the same error.


Freesurfer version 7.1.1
Freeview dev/standalone & version packaged with Freesurfer 7.1.1

Environment (Docker, Singularity, custom installation):

2019 MacBook Pro 16 Inch, Intel core i9
AMD Radeon Pro 5500M / Intel uhd graphics 630
Ventura 13.4.1
No container/VM

Data formatted according to a validatable standard? Please provide the output of the validator:

Surfaces and volumes which caused crashes were standard outputs of recon-all, and have worked recently in Freeview without issue.

Relevant log outputs (up to 20 lines):

FREESURFER_HOME/bin/freeview: line 2: 1788 Segmentation fault: 11 FREESURFER_HOME/ "$@"

Mac Diagnostic Report for Freeview (file is quite a bit longer than this snippet):

Process:               freeview [1788]
Path:                  /Users/USER/*/
Identifier:            com.freesurfer.freeview
Version:               ???
Code Type:             X86-64 (Native)
Parent Process:        Exited process [1787]
Responsible:           iTerm2 [425]

Date/Time:             2023-12-15 11:10:43.6654 -0800
OS Version:            macOS 13.4.1 (22F770820d)
Report Version:        12
Bridge OS Version:     7.5 (20P5060)

Time Awake Since Boot: 1200 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue:

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000028
Exception Codes:       0x0000000000000001, 0x0000000000000028

Termination Reason:    Namespace SIGNAL, Code 11 Segmentation fault: 11
Terminating Process:   exc handler [1788]

VM Region Info: 0x28 is not in any region.  Bytes before following region: 140737487114200
      REGION TYPE                    START - END         [ VSIZE] PRT/MAX SHRMOD  REGION DETAIL
      shared memory            7fffffed1000-7fffffed2000 [    4K] r-x/r-x SM=SHM

Hi @bprxr,

Just making sure, does your $FS_LICENSE variable point to a valid FS license?


Hi Steven, thanks for your help! Yes my license.txt is in $FREESURFER_HOME, and $FS_LICENSE points to that file

I might try asking this in the FreeSurfer mailing list if you have not already: FreeSurferSupport - Free Surfer Wiki

Will do, thanks! I’ll try that next :slight_smile: all the best