‘IntendedFor’ field needs to point to an existing file

Dear community,

I have inserted the IntendedFor field to my AP and PA b0 images of the DWI data in corresponding JSON files which points to the DWI data. The DWI image is present, but still, the bids-validator complains and gives the following error:
Location
UC042121QA/sub-QA042121/ses-phantom/fmap/sub-QA042121_ses-phantom_acq-dwib0_dir-AP_epi.nii.gz

Reason
'IntendedFor' property of this fieldmap ('/sub-QA042121/ses-phantom/fmap/sub-QA042121_ses-phantom_acq-dwib0_dir-AP_epi.nii.gz') does not point to an existing file('ses-phantom/dwi/sub-QA042121_ses-phantom_dwi.nii.gz'). Please mind that this value should not include subject level directory ('/sub-QA042121/').

Evidence
ses-phantom/dwi/sub-QA042121_ses-phantom_dwi.nii.gz

I have seen this relevant post, but it does not seem to be my case.

This is how I have inserted the IntendedFor field:
"IntendedFor": ["ses-phantom/dwi/sub-QA042121_ses-phantom_dwi.nii.gz"],

Even if I pass the path to DWI data as a string and not as a list, I still get the same error. I also have the correct permissions in my parent directory. Is there any issue with any keyword in the subject/session name maybe e.g. phantom?

Please help!
Thanks.

Try removing the session level from the path. Doubt it will work, but worth a shot.
"IntendedFor": ["dwi/sub-QA042121_ses-phantom_dwi.nii.gz"],

No, it does not help! Same error message.

@meet10may have you tried opening an issue with the bids-validator group here? They may be able to assist you.

Solved! For some unknown reason, after my dicoms were converted to bids, my DWI data was added to the .bidsignore file! Once I removed it from the .bidsignore file, the data passed the bids validation. Thanks for all the help!

MANAGED BY INCF