Ipywidget does not show in Jupyter lab, but works in Jupyter notebook

Hello folks,

I have tried everything to get ipywidgets to work properly in Jupyter lab, including everything I’ve found on stackoverflow/google/git issues. But the widget only works in Jupyter notebooks, and does not display AT ALL (not even the object strings) in Jupyter lab.

Here’s everything I have in my environment + things I’ve tried:
jupyter lab --version: 0.35.4
nodejs version: v11.9.0

       app dir: /home/axiezai/miniconda3/share/jupyter/lab
        @jupyter-widgets/jupyterlab-manager v0.38.1  enabled  OK

Following this requirement: JupyterLab 0.35.x, use jupyter labextension install @jupyter-widgets/jupyterlab-manager@0.38

I’ve made sure that jupyterlab-manager is installed in my base environment, and ipywidget installed in my working environment.

I’ve also done a jupyter lab clean and re-installed the extension, then restarted jupyter lab, still doesn’t work.

From many issues that were raised over the past, Jupyter lab’s cell actually spits out an object output, just no slider. But in my case, the lab’s cell does not spit out the object, just the plot/output. I’ve attached a screenshot, the code is from ipywidget’s example:

The only thing I can think of is nodejs version compatibility maybe?
If anyone can help me debug this, I would be very grateful, thank you all! Much love.

Please let me know if you need any other information!