Issue With Fieldmaps: "None ... has the right phase encoding direction"

I have been trying to run fmriprep on a dataset with functional MRI data from Siemens Prisma Fit. I have tried running versions 1.4.0, 1.5.0, 1.5.10, and 20.1.0, but each time I try to run it, I run into the following error:

The metadata looks correct. The distortion maps for the AP and PA direction have the right j- and j directions, respectively, in the corresponding json. Our bold images were run in the PA direction. I have attached the jsons from both runs of our bold data as well as the corresponding fieldmaps. We were able to run fmriprep with the --fieldmaps ignore tag, but we want to actually include distortion correction in our analyses. Is there something obvious we are missing? What should we be checking to prevent/fix this error with the fieldmaps?

sub-PC1210CPC_ses-1_acq-ER_dir-AP_epi.txt (2.9 KB) sub-PC1210CPC_ses-1_acq-ER_dir-PA_epi.txt (2.9 KB) sub-PC1210CPC_ses-1_task-ER_run-01_bold.txt (2.7 KB) sub-PC1210CPC_ses-1_task-ER_run-02_bold.txt (2.6 KB)

Thank you so much for your time and assistance.


Lauren Ericksen
Study Coordinator
University of Utah, Department of Psychiatry