Issues installing fMRIprep with Singularity

Dear all,

I am quite a newbie to neuroimaging and I am setting up my laptop to make thw most important programms run. Unfortunately, I’m having troubles installing fMRIprep with Singularity.
I tried to run the following command from the fMRIprep homepage (

I replaced with 20.2.0, which should be the most recent fMRIprep version (if I am not mistaken).

singularity build /my_images/fmriprep-<version>.simg docker://nipreps/fmriprep:<version>

Running this command starts an installation process, which fails with the following error:

(I get a lot of this exploding layer errors)

In addition, I also tried to run the command with sudo-rights, same result.

Is there anything I can do? Any help is highly apprechiated – thank you very much! :slight_smile:

Best regards,

P.S.: My operating system is debian 10 (buster) and the singularity version installed is 2.6.1.

The screenshot you posted contains the message Could not create destination file: No such file or directory Does the directory /my_images exist on your machine? What if you try a different output path?

Thank you for your late answer and I apologize for the late reply!

Well, that path was generated automatically, I am not sure how to change it. But I worked my way around it by using the docker-container, which works (for now). I will try to change the output path in future if I need singularity :slight_smile:

Still, thank you for having a look at it! :slight_smile:

Hi @Ank13, it would be beneficial for the community that you reported back whether @heffjos’ suggestion solves this problem. Could you give it a try?

Yes, I will have a look and reply after I tried it!