Issues with the results generated by dHCP structural pipeline with the non-dHCP data


I am processing non-dHCP image using the dHCP structural pipeline with the following command:

docker run --rm -t
-u (id−u): (id -g)
-v $PWD/data:/data
biomedia/dhcp-structural-pipeline:latest sub-zhangjunxia ses-001 39
-T2 data/_t2_space_sag_p3_iso_20230727110000_20001.nii.gz -t 8

but I’ve got some strange results shown below (abnormal pial swelling and abnormal cortical thickness distribution). The pipeline seems run correctly and I don’t where the bug happened.

Your help is highly appreciated,

Hi Zhao,

The most likely issue with this that this pipeline adjusts placement of the pial surface after using the cortical ribbon as an initialisation. There is an older version of the pipeline that can be used without this adjustment.

You can use the pipeline and include an additional -recon-from-seg flag.

Let me know if that works

Best wishes,


Hi lziwilliams,

Thank you for your reply. I have tried my best to install this version of the pipeline on my local Linux machine. Anyway, I failed. Is there a docker image of this version of the pipeline?

Best wishes,

Hi lziwilliams,
Thank you very much. Your reply really worked for my question. THX.
Best wishes,