It seems like nipype current version not compatiable with current python version

Summary of what happened:

When python is listed in the .yml file of the conda enviroment, the previous version of nipype is installed


when I use this .yml file for my conda python v3.11.6 and nipype v1.8.5 are installed

whereas when I delete python from the .yml file python v3.10.13 and nipype v1.8.6 are installed

Is there any way to for the newest version of nipype to get priority?

Thanks in advance,

You can’t install nipype through conda for Python 3.11. Nipype depends on enthought traits, which broke everything at traits 6.4, and nobody has had the energy or interest to make nipype compatible with traits 6.4+. Unfortunately, there are no 3.11 conda builds for traits 6.3.

However, traits 6.3 still builds on later Pythons, so as long as you install through pip and have a C compiler on your system, then you can use nipype on more recent versions.