Mindboggle runtime error related to FreeSurfer license

I am trying to do a test run using the one line command with the T1 image from the example input data. After almost 30 hours of running, I got an runtime error as followed:

Traceback (most recent call last):
File “/opt/miniconda-latest/envs/mb/bin/mindboggle123”, line 408, in
File “/opt/miniconda-latest/envs/mb/lib/python3.6/site-packages/nipype/pipeline/engine/workflows.py”, line 595, in run
runner.run(execgraph, updatehash=updatehash, config=self.config)
File “/opt/miniconda-latest/envs/mb/lib/python3.6/site-packages/nipype/pipeline/plugins/linear.py”, line 61, in run
File “/opt/miniconda-latest/envs/mb/lib/python3.6/site-packages/nipype/pipeline/plugins/tools.py”, line 82, in report_nodes_not_run
raise RuntimeError(('Workflow did not execute cleanly. '))
RuntimeError: Workflow did not execute cleanly.

and I looked into the freesurfer_subjects/TEST_ID/scripts/recon-all.log, it has this error:

ERROR: FreeSurfer license file /opt/freesurfer-6.0.0-min/license.txt not found.
If you are outside the NMR-Martinos Center,
go to http://surfer.nmr.mgh.harvard.edu/registration.html to
get a valid license file (it’s free).
If you are inside the NMR-Martinos Center,
make sure to source the standard environment.

Does anyone have the same problem or have the solution for it?


Ahoi hoi @leona,

thank you very much for your post and welcome to neurostars, it’s great to heave you here.

Could you maybe provide more information on how you run mindboggle, including specific command, setup and version?
From the processing time I assume you were running it on a local, not very powerful machine, as 30 hours is very long. Especially, as this error happens right at the beginning of the FreeSurfer pipeline.

Cheers, Peer

Hi @PeerHerholz Thanks for the response!
I was running in on a server but the server was extremely slow these days and all jobs took longer time to finish than usual. Here are the commands I ran:

HOST=/Leona/test-mindb # this is the path where I have the T1 image
DOCK=/home/jovyan/work # path to HOST from Docker container
IMAGE=$DOCK/T1.nii.gz # brain image in $HOST to process
ID=Test_id # I set a random id for testing
OUT=$DOCK/mindboggle123_output # output path
docker run --rm -ti -v $HOST:$DOCK nipy/mindboggle mindboggle123 $IMAGE --id $ID


Ahoi hoi @leona,

thank you very much for providing more information.
Oh, you’re running docker on a server? Never thought, I’d hear that!

Hm, your command looks right and problems in the command itself won’t explain
the error you received. When did you pull the image? The latest build should have a FreeSurfer license.txt (please have a look at the corresponding section in the Dockerfile).
I just pulled the image via docker pull nipy/mindboggle and the license.txt is where it should be:

Cheers, Peer

1 Like

Thanks a lot @PeerHerholz for your answer! I re-pulled the image and -re ran it, and it works now!
One more quick question regarding the output, I saw an exploded folder in my output and that is not included when Mindboggle’s documentation is demonstrating the standard output . Any idea what is that folder for?


Ahoi hoi @leona,

cool, glad that it works now!
Yeah, good point (@binarybottle should a little explanation be added to the docs?)!
If you have a look at the exploded directory, you’ll see that it contains, for both hemispheres, the shape features for each label of the used atlas in .vtk and .csv.
This information can be found in summarized versions within the shapes and tables directories, which is what you most likely will use for further analyses (depending on your project of course).

HTH, cheers, Peer

Thank you so much for your help as always, Peer!

I would be happy to include any descriptions in the docs that would add clarity, but I’m not clear myself what to say here. Is it that when setting up on a server you have to do something different with the freesurfer license file? Please explain.

Hi @binarybottle,

thanks for the response! No biggie, happy to help.

We solved the initial problem through pulling the latest version of the mindboggle image.
My question/comment targeted the exploded folder mentioned by @leona, in that it
can be found in the output directory, but is not explained in the docs.

Best regards and thanks again, Peer