MRIQC docker container: runtime error return code 137

Hello. I ran MRIQC docker command:

docker run -it --rm -v /c/Users/Username/Documents/BIDS_data:/data:ro -v /c/Users/Username/Documents/mriqc-output:/out poldracklab/mriqc:latest /data /out participant --participant_label 008 --no-sub

It terminated in between giving runtime error code 137.

I am using docker toolbox on WSL1 (Cannot upgrade to WSL2 because windows updates 2004 has not reached to my system yet). As I found out about error code 137, it is related to RAM limit for docker. Since I am using docker toolbox, the only option to change docker settings is through VM virtualbox and I was unable to find any option to change memory settings there.

Is there any way that I can use mriqc and get results?


Hi @Tajwar seems like it is caused by memory starvation. The usual recommendation is to use Docker Desktop instead of Docker Toolbox, but since you cannot update as mentioned, you could try out the following:

Step 1: Remove the existing Docker VM

docker-machine rm default

Step 2: Create a new VM with an increased amount of RAM (Depends on the RAM available on your PC). In this sample command, I will include 4GB RAM:

docker-machine create -d virtualbox --virtualbox-cpu-count=2 --virtualbox-memory=4096 --virtualbox-disk-size=50000 default

Now restart Docker and run the command.

Thanks @sanjula. It solved the problem.

1 Like

Great! Happy to know it got solved. Let us know if there are other queries, the community is always there to help! :slight_smile: