MRIQC / ModuleNotFoundError: No module named ‘niworkflows.interfaces.utils’

Hi there,

I’m running MRIQC on one subject with docker but running into the following problem:

ndyxs@ndyxs-thinkserver:~$ docker run -it --rm -v /media/ndyxs/WD12_3/test20211008/bidsdata/:/data:ro -v /media/ndyxs/WD12_3/test20211008/MRIQC_output/:/out poldracklab/mriqc:latest /data /out participant --participant_label sub-0100
211009-05:25:22,386 cli IMPORTANT:

Running MRIQC version 0.16.1+81.g0093e62.dirty:
  * BIDS dataset path: /data.
  * Output folder: /out.
  * Analysis levels: ['participant'].

Process Process-2:
Traceback (most recent call last):
File “/opt/conda/lib/python3.8/multiprocessing/process.py”, line 315, in _bootstrap
self.run()
File “/opt/conda/lib/python3.8/multiprocessing/process.py”, line 108, in run
self._target(*self._args, **self._kwargs)
File “/opt/conda/lib/python3.8/site-packages/mriqc/cli/workflow.py”, line 21, in build_workflow
retval[“workflow”] = init_mriqc_wf()
File “/opt/conda/lib/python3.8/site-packages/mriqc/workflows/core.py”, line 22, in init_mriqc_wf
workflow.add_nodes([fmri_qc_workflow()])
File “/opt/conda/lib/python3.8/site-packages/mriqc/workflows/functional.py”, line 43, in fmri_qc_workflow
from niworkflows.interfaces.utils import SanitizeImage
ModuleNotFoundError: No module named ‘niworkflows.interfaces.utils’

I have tried to install niworkflows but the same problem still exists.

Anyone know how to fix it I would appreciate your help :slight_smile:

Thank you very much!

Are you by chance using a working directory that has results from a different MRIQC version? Try specifying a clean working directory and see if you get the same error.

Hi Steven - Nope. That was my first time downloading MRIQC. However, this issue was fixed after I switching to nipreps/mriqc:21.0.0rc2.

1 Like

MANAGED BY INCF