MRIQC related issue

Hi,
I tried to implement MRIQC on an open access dataset ABIDE 1(KKI, CALTECH and CMU), which consists of 100 subjects MRI data but classification procedure is not executing properly and raising an error “Data contains either NaN values or float exceeding the limit”. As this is the same dataset from which mriqc classification model is trained, so this issue is not supposed to be there.

Also, when I applied the MRIQC on 20 subjects of ABIDE 1 dataset (KKI), it is rejecting the two subjects MRI data and when the same is applied on the 6 (previously considered) subjects then it is accepting the discarded subject’s data.

The output should be consistent. I request your comment

We need way more information than this to reconstruct what happened.
About MRIQC:

  • Exact version with which you are getting this error
  • Platform and installation, containers?
  • Command line (and any other information to know precisely what you are attempting to do).

About the three particular sites of ABIDE I you are using:

  • Did you add any processing? How did you convert those data to BIDS?

About what you want to do:

  • It seems you want to get automated ratings from the MRIQC classifier. I’d advise against using these from ABIDE I because these are the actual examples we used in training! You should expect an almost-perfect classification.

Without the command line and any other details about what you plan to do, it is really hard for me to understand the question and the problem.

Consistent should be defined prior to this statement. Isn’t this more of your (legitimate) expectation?

For run-to-run reproducibility to the last bit, in our MRIQC paper there are links to the singularity images we used at the moment for the paper. It is still not guaranteed that you’ll have such large consistency, but they should get you close enough.

I appreciate your quick response.

The complete information about MRIQC is as follows:

Version of MRIQC: mriqc:0.15.1

Commands i am using to run are:

IQM generation command is:

sudo docker run -it --rm -v ’ inputFolderPath ‘/00_IQA/’ ':/data:ro -v ’ inputFolderPath ‘/00_IQA_Results/’ ':/out poldracklab/mriqc:0.15.1 /data /out participant -m ’ conType ’ --verbose-reports --no-sub --nprocs ’ num2str(numCores) ’ --ants-nthreads ’ num2str(numCores)]

classifier command is:

'sudo docker run -v ’ inputFolderPath ‘/00_IQA_Results/’ ':/scratch -w /scratch --entrypoint=mriqc_clf poldracklab/mriqc:0.15.1 --load-classifier --njobs ’ num2str(numCores) ’ -X ’ ‘group_T1w.tsv’

I am using ABIDE1 dataset from “http://fcon_1000.projects.nitrc.org/indi/abide/abide_I.html” (KKI, CALTECH and CMU)

I didnt perform any pre-processing on the raw data and just converted the data to BIDS format. I am sharing the folder screenshot for BIDS format.

If you need any other information please let me know.

1 Like

Hi @Komal_Jindal! It’s interesting that you’re saying you brought ABIDE into BIDS format. Would you like to share which were your changes? Using the BIDS-verification tool, I get that the dataset isn’t BIDS-compatible. Especially worrying is the TR time which is missing and I am not exactly sure on how to add the data (there’s a Resources file where the TR is noted depending on the lab and also it seems to exist on the nifti header but still the error arises).

Anyway I hope that you have some tips :slight_smile: Thanks!