Naming change confounds_regressors to confounds_timeseries

Hello - maybe I’m being dense and just can’t find it, but when/why did fmriprep move from naming the desc-confounds_regressors.tsv file to desc-confounds_timeseries.tsv?

I noticed in the difference between 20.1.1 and 20.2.0 but I can’t find the documentation in the changlog.

This was a pre-emptive conformation of derivatives to BEP 012 - Functional derivatives.

The idea is to reduce the number of times we change outputs to conform to standards. Since this change was discussed some time ago and has been stable (although unreleased), it seemed a good time to change. Hopefully this will avoid another round of changes after BEP 012 is merged.

Thanks and makes sense. I have no problem with the change, I was just curious because I noticed it.

Cool. Apologies that we didn’t declare that change more clearly.

1 Like

MANAGED BY INCF