Naming fieldmaps

To follow up on my “outside of the brain fMRI data” issue, I am trying to use phase field maps. For each run there are 2 phasic field maps. I also have two tasks, namely “CCD” and “loca”. I named the filed maps like ‘sub-01_task-CCD_run-02_phase1.nii.gz’, tried this on BIDS validator but got errors. I then renamed them to '‘sub-01_run-01_phase1.nii.gz’ and they worked well. But I am wondering, by naming filed maps like this, how would fmriprep know which filed maps correspond to which fMRI runs?
Thanks again!

You can to specify this in the sub-01_run-01_phase1.json file using the IntendedFor field. See more (including details of file naming scheme) in section 8.3.5 of the spec:

1 Like

Hi folks,

Sorry to bump an old thread, but I’m trying to get some clarification on an issue brought up here. I’m new to fmriprep and I’m in the process of getting my dataset ready. I have task fmri with two runs, but looking to use one pair of pepolar/spin echo field maps. From what I’m learning, I can edit the json files of the fieldmaps to include an IntendedFor field to let fmriprep know to use the same set for both task runs.

Currently, the json files I have do not have the IntendedFor field, so I’m wondering if it matters where that field is inserted in the json file? According to BIDS v 1.4.0 examples, the IntendedFor field can be found after “EchoTime” in Cases 1 &2, “Units” in Case 3, and “TotalReadoutTime” in Case4.

This may be a silly question, but I just want to ensure that I correctly specify that the same pair of fieldmaps are to be used on two runs of task fMRI. Additionally, since I’m planning on writing a script to make these modifications, any insight on this would be greatly appreciated. Thanks!

Hi @crodriguez, ordering does not matter.

Awesome! That helps a lot. I’ll just insert the IntendedFor field right before the end of each json file. I have data from multiple scanners and each json file is a bit different in length and figuring out a fixed position for each scanner type would have been a little trickier. Thanks!