Neurodocker feat issues

My sysadmins are having trouble building fsl on our new cluster using easybuild so I thought I’d try a fsl neurodocker singularity container as an alternative. I can get basic commands like bet to run, but feat will not run. I’ve also tried in a docker on my mac which has the same error. But I can get the same model to run successfully when I run it locally with FSL on my mac. Here’s the error code I’m getting:

[joseph.orr@tnxt-0665 sub-01] singularity run /scratch/user/joseph.orr/fsl_603.sif feat ses-test_task-fingerfootlips_preproc.fsf Some packages in this Docker container are non-free If you are considering commercial use of this container, please consult the relevant license: child process exited abnormally while executing "fsl:exec "{FSLDIR}/bin/feat ${fsfroot}.fsf -D $FD -I $session -prestats" -b $prestatsTime -h $initID $jobHalt -N feat2_pre -l logs "
(procedure “firstLevelMaster” line 168)
invoked from within
“firstLevelMaster $session”
invoked from within
"if { $done_something == 0 } {

       if { ! $fmri(inmelodic) } {
          if { $fmri(level) == 1 } {
   	      for { set session 1 } { $session <= $fmri(mult..."
       (file "/opt/fsl-6.0.3/bin/feat" line 390)