Nibabies B0 Fieldmap Association Error: Need for "IntendedFor" Field in JSON File?

Hi there! I’m currently working with Nibabies and encountering an issue. When I try to run it, I receive an warn message stating, “None of the available B0 fieldmaps are associated to </data/sub-12012/ses-newborn/func/sub-12012_ses-newborn_task-rest_dir-PA_run-01_bold.nii.gz>.” Upon searching this problem, I noticed that someone mention the necessity of an “IntendedFor” field in the json file. So, my question is: if my json file does not have the “IntendedFor” field, Nibabies was just unable to automatically apply corrections based on the field map files located in the bids/fmap directory? Any help on this matter would be greatly appreciated. Thank you in advance!

Hi @Yanbin_Niu and welcome to neurostars!

Correct. One may collect multiple field maps over the course of a study, with some field maps intended for particular scans. Without the IntendedFor field (or alternatively the B0FieldSource/Identifier fields), BIDS apps have no way of knowing which field map you want associated with each scan.


Hi @Yanbin_Niu,

At the very least it looks like your field maps were recognized this time around. Can you confirm the phase encoding directions are correct in your BOLD and fmap files?


Hi @Steven , I’ve taken a closer look at the raw data and realized that the quality of the data for this particular subject isn’t ideal, which might have led to some confusion earlier. Apologies for any inconvenience caused!

I tried to run Nibabies with a different subject and it worked perfectly – the report is now correctly updated in the HTML file. I can’t thank you enough for your responses; they’ve been tremendously helpful!

By the way, version 21.0.1 of Nibabies can perform field map correction without the need to specify the ‘IntendedFor’ field in the JSON file. It’s great to be aware of these significant updates.

1 Like

For those who might find it useful, I’d like to share a summary of the solution I used. I worked with nibabies version 23.1.0, which does not automatically correct for field maps (fmaps). I have to manually add the ‘IntendedFor’ field in the fmap JSON file. The field should look something like this:

"IntendedFor": [