NiMARE example notebooks - what version of nilearn?

Hi Taylor,

I am hoping to use the example notebook, 03_plot_compare_ibma_and_cbma.ipynb, as a teaching tool for an intro to meta-analysis lecture.

I have it up and running on mybinder, but I am getting an error message at the nilearn plot_stat_map step for the ALE step. It is something having to do with the command passing too many values to cbar._mesh.

I’m guessing that I should be using an older version of nilearn. Do you remember what version you used when you set up the example notebooks?

I hunted a bit through the NiMARE github repository and documentation, but I couldn’t find a specific list of required packages and versions.



Hi Suzanne,

The best nilearn version for running the examples is 0.7.1, at the moment. There were some recent changes to the default templates in 0.8+ that caused issues with NiMARE.

The specific dependencies and associated versions aren’t in the documentation, but you can find them in nimare/


Hi Taylor,

Thanks for the response.

I was able to find a work around by forcing my environment to use matplotlib 3.1.0. The value error I was getting appears to only affect matplotlib >= 3.2.0.

But, I’ll see whether forcing nilearn=0.7.1 also works.