Problem using mriqc with singularity and docker2singularity

Hi all,

I am trying to run MRIQC on a large dataset on an HPC. I want to use Singularity for that.
If I am correct, I first have to build a singularity image using dockers and docker2singularity. On our cluster, singularity 2.5.1 is installed.

  • So my first question is, do I still need to build an image using docker or can I directly run MRIQC in this singularity version? Some older forum posts suggest that it might be possible to have singularity directly pull MRIQC in newer versions (>2.3). I am new to using docker and singularity, so if this is the case can anyone point me to instructions how to use mriqc directly using singularity?

  • In the meantime, according to instructions (e.g., for fmriprep I have tried to make an image using dockers. My old MacBook Pro (2011, 8GB RAM) took hours to do this and now it seems to hang in the final step :frowning:

(9/9) Moving the image to the output folder…
456,753,152 3% 3.79MB/s 0:48:44

Is there some other way to retrieve the image? It says it is in /tmp/poldracklab_mriqc_latest-2018-03-23-8f4d663746b9.img, but I cannot find this on my HD so it is probably on the server?
I would also be glad if there is an image online that is already build by someone else, so I can download that file.

Many thanks in advance,

Indeed on systems with more up to date installations of singularity you can do

singularity build /path/where/you/want/to/store/container/images/mriqc-0.11.0.simg docker://poldracklab/mriqc:0.11.0

Not quite sure what is going on here. Have you tried restarting Docker?

It’s inside the container.

That would be great, but we have not found a CI service that could do this in an automatic way. Maybe one day!

Great, thanks for the help! Was now able to pull the image directly on the cluster. However, I run into problems with root permissions when using the container on HPC. Try to fix that now.

Seemed to do with disk size (the container image was huge, HD ran out of space). After making space available it worked fine

Many thanks for the help!

1 Like