Problem with BIDS not recognising multi echo multi band resting state data

Hi everyone,

I’m Bec Kerestes, a neuroscientist at Monash University and first-timer on Neurostars.

I am working with BIDS for the first time and have run into some problems. I have followed along the tutorial given here: First steps - Dcm2Bids
I have also downloaded an example data set, wrote a config file and got the BIDS conversion to work successfully. However i am having trouble running BIDS conversion on my study. Screenshot of my config file is below:

It is a multi-band multi-echo rs-fmri sequence with 4 echos. I have listed the EchoNumber for each one, as it appears in the .json file. When I run the dcm2bids command I get the following error:
No pairing ← 004_SubjectID_Rest_R_L_mmb_4_4…_e1
No pairing ← 004_SubjectID_Rest_R_L_mmb_4_4…_e2
No pairing ← 004_SubjectID_Rest_R_L_mmb_4_4…_e3
No pairing ← 004_SubjectID_Rest_R_L_mmb_4_4…_e4

It is having trouble pairing the resting state sequence. I have wrangled with this for many hours and can’t seem to resolve it. Any help is appreciated!



It might help if you could also send us a screenshot of one of the JSONs from the converted DCMs. Have you run the dcm2bids helper function on one subject, which would produce these?


Hi Steven,
Thank you for your reply. After some fiddling, I got it to work. However I am still having 2 other small issues.

  1. because the resting state sequence is a multi-echo sequence with 4 echos, the dcm2nix results in 4 .json and 4 .nii.gz files. However when I run dcm2bids it prints a message in terminal “4 resting state runs were detected” and it isn’t naming the resultant files in BIDS format: the expected sub-subID_task-rest_echo-1_bold.nii.gz/.json, sub-subID_task-rest_echo-2_bold.nii.gz/.json etc and instead is labelilng the files as shown below. Will this require a manual step to rename the files??


  1. I’m having trouble with the fieldmaps. I have 2 mag and 1 phase image. When I run dcm2bids the magnitude1 image is produced, but the phasediff is not- there is an error saying no pairing. I read here: bids-validator — neuroimaging core 0.1.1 documentation that in the phase diff sidecar file you must list both echo times. I tried that but it still didn’t work. When I open the .json file of the phase diff image there is only one echo time listed. Do i need to manually add both echo times in, and run again? Here is a copy of what the json file looks like for my gradient field phase image:

In my config file I specify the sidecarfilename as 007* and I list “echo time” :2 in my config file.

Thank you in advance for your help.