Problems implementing top up scan in fmriprep 21.0.1

Dear all,

Since the new update of fmriprep 21.0.1 we are trying to preprocess our data with the top up scans. We tried it on two separate sessions of one subject first to see whether it works. On one of them, it worked and gave the right output, but on the other it did not work.
Here the trees for the two sessions:
/dbstore/Rijnstate/SYNAPSE/BIDS4/sub-0071 (for this session it works!)
├── anat
│ ├── sub-0071_T1w.json
│ └── sub-0071_T1w.nii.gz
├── fmap
│ ├── sub-0071_dir-AP_epi.json
│ └── sub-0071_dir-AP_epi.nii.gz
└── func
├── sub-0071_task-rest_bold.json
└── sub-0071_task-rest_bold.nii.gz

/dbstore/Rijnstate/SYNAPSE/BIDS4/sub-0073 (for this session it does not work…)
├── anat
│ ├── sub-0073_T1w.json
│ └── sub-0073_T1w.nii.gz
├── fmap
│ ├── sub-0073_dir-AP_epi.json
│ └── sub-0073_dir-AP_epi.nii.gz
└── func
├── sub-0073_task-rest_bold.json
└── sub-0073_task-rest_bold.nii.gz

Both _epi.json files are identical expect from the field ’ IntendedFor ’ .
For the second session (0073), we do not get an error, but the top up scan is simply not taken into account.
The data are conform BIDS structure.

Thanks for your help!

What are in the intended for fields for the working and non-working fmaps?

Hi Steven,
Thanks for the quick reply. Here the json file of the working session:
“EstimatedTotalReadoutTime”: 0.0240456,
“TotalReadoutTime”: 0.0240456,
“PhaseEncodingDirection”: “j-”,
“IntendedFor”: “func/sub-0071_task-rest_bold.nii.gz”

And here for the non-working session:
“EstimatedTotalReadoutTime”: 0.0240198,
“TotalReadoutTime”: 0.0240198,
“PhaseEncodingDirection”: “j-”,
“IntendedFor”: “func/sub-0073_task-rest_bold.nii.gz”

Hmm, that looks right. Can you confirm that the phase encoding directions of both BOLD runs are j+?

Dear Steven,

Thanks for thinking along with our problem. We solved it, by deleted the field EstimatedTotalReadoutTime that was still in the json files of our BOLDs. TotalReadoutTime was also a key in the json files, but apparently 2 of these keys were one too many. It works now! So we need to have the exact same fields in both, the top up and the BOLD jsons.

Best, Julia