Question about msmsulc error

Hi fMRIPrep experts,

Summary of what happened:

I started to use fMRIPrep v23.2.0 recently, but the following errors occurred at last, though almost all processes seemed to have done perfectly. There were 2 nodes (_msmsulc1 and _msmsulc0) failed. Could you please provide some advice to fix these errors? I look forward to hearing from you.

Command used (and if a helper script was used, a link to the helper script or the command generated):

fmriprep /data $Home/output_sub-0027 participant --fs-license-file $Home/license.txt -w $Home/work_sub-0027 --mem-mb 64000


fMRIPrep v23.2.0

Environment (Docker, Singularity, custom installation):

custom installation

Data formatted according to a validatable standard? Please provide the output of the validator:


Relevant log outputs (up to 20 lines):

(There was one more same error as the following. )

Traceback (most recent call last):
  File "$Home/.pyenv/versions/3.10.13/lib/python3.10/site-packages/nipype/pipeline/plugins/", line 67, in run_node
    result["result"] =
  File "$Home/.pyenv/versions/3.10.13/lib/python3.10/site-packages/nipype/pipeline/engine/", line 527, in run
    result = self._run_interface(execute=True)
  File "$Home/.pyenv/versions/3.10.13/lib/python3.10/site-packages/nipype/pipeline/engine/", line 645, in _run_interface
    return self._run_command(execute)
  File "$Home/.pyenv/versions/3.10.13/lib/python3.10/site-packages/nipype/pipeline/engine/", line 771, in _run_command
    raise NodeExecutionError(msg)
nipype.pipeline.engine.nodes.NodeExecutionError: Exception raised while executing Node _msmsulc1.

	msm --conf=$Home/.pyenv/versions/3.10.13/lib/python3.10/site-packages/smriprep/data/msm/MSMSulcStrainFinalconf --indata=$Home/work_sub-0027/fmriprep_23_2_wf/sub_027_wf/anat_fit_wf/msm_sulc_wf/invert_sulc/mapflow/_invert_sulc1/sub-XYZ.R.sulc.native.shape.gii --inmesh=$Home/work_sub-0027/fmriprep_23_2_wf/sub_027_wf/anat_fit_wf/msm_sulc_wf/modify_sphere/mapflow/_modify_sphere1/ --out=rh. --refdata=$Home/.pyenv/versions/3.10.13/lib/python3.10/site-packages/smriprep/data/atlases/R.refsulc.164k_fs_LR.shape.gii --refmesh=$Home/.pyenv/versions/3.10.13/lib/python3.10/site-packages/smriprep/data/atlases/ --verbose

	usage: msm [-h]
	           [-p {default,mycroft_mark_1,kde,respeaker,mycroft_mark_2pi,picroft,mycroft_mark_2}]
	           [-u REPO_URL] [-b REPO_BRANCH] [-d SKILLS_DIR] [-l] [-r]
	           {install,remove,search,info,list,update,default} ...
	msm: error: the following arguments are required: action
	RuntimeError: subprocess exited with code 2.

Screenshots / relevant information:

Above the error, the following information could be seen in subject summary:


Node Name: _msmsulc1

File: $Home/output_sub-0027/sub-027/log/20240113-041805_4a807f1b-7693-45f7-9ebd-a337c523a176/crash-20240113-044207-t_yatomi-_msmsulc1-9da240dc-4704-4475-834f-1f0813b48a69.txt
Working Directory: $Home/work_sub-0027/fmriprep_23_2_wf/sub_027_wf/anat_fit_wf/msm_sulc_wf/msmsulc/mapflow/_msmsulc1

  • args:``
  • config_file: $Home/.pyenv/versions/3.10.13/lib/python3.10/site-packages/smriprep/data/msm/MSMSulcStrainFinalconf
  • environ: {}
  • in_data: $Home/work_sub-0027/fmriprep_23_2_wf/sub_027_wf/anat_fit_wf/msm_sulc_wf/invert_sulc/mapflow/_invert_sulc1/sub-XYZ.R.sulc.native.shape.gii
  • in_mesh: $Home/work_sub-0027/fmriprep_23_2_wf/sub_027_wf/anat_fit_wf/msm_sulc_wf/modify_sphere/mapflow/_modify_sphere1/
  • in_register:``
  • in_weight:``
  • levels:``
  • out_base: rh.
  • output_format:``
  • reference_data: $Home/.pyenv/versions/3.10.13/lib/python3.10/site-packages/smriprep/data/atlases/R.refsulc.164k_fs_LR.shape.gii
  • reference_mesh: $Home/.pyenv/versions/3.10.13/lib/python3.10/site-packages/smriprep/data/atlases/
  • reference_weight:``
  • smooth_output_sigma:``
  • transformed_mesh:``
  • verbose: True

Best regards,

Hi @Taisuke,

Thanks for the report. Can you confirm you get the same error with a containered installation (docker or singularity/apptainer)?


1 Like

You need to add Emma Robinson’s MSM to your path. Whatever msm you have isn’t the right tool.

1 Like

Hi Steven,

Thank you so much for your quick reply, fMRIPrep v23.2.0 worked successfully in my local PC with Docker without errors I mentioned!

Kind regards,

Hi @effigies,

I appreciate your immediate response and informing me of detailed information very much. I will try to add Emma Robinson’s MSM to my path.


Hi @Taisuke,

Glad it worked! You only need to modify paths if you are not using containers. The nice thing about containers is that it ensures all the software dependencies are correct without you having to manually install them.


1 Like