Run Topup, but not Eddy; How to deal with different acquisition parameters

Hi Tractoflow team,

I do QC with DTIPrep, which does Eddy + motion correction as well as automated volume removal, before using Tractoflow. Therefore, I do not need to do Eddy and motion again so I set --run_eddy false. However, DTIPrep does not do Topup, and some of my datasets have reverse b0 images. In the Slurm outfile, it looks like Eddy and Topup are one process (called Eddy). Is it possible to only run topup, or should I run topup before using Tractoflow?

Similarly, in this dataset there are some subjects who have reverse-encoded b0 and some who do not. What would be your suggested way of dealing with this? My main concern is that ideally all subjects would be considered in the mean FRF.

Thank you,

Hi Steven,

Sorry for my late response. In fact, you must run eddy because eddy run Topup too. The Topup step extract all the deformation maps and Eddy apply the deformation field.

For your second question you have 2 choices:

You run TractoFlow twice. One with all subject with rev_b0 and one with all subject without. However, the response function will be slightly different across your 2 groups.

You can set the response function and not compute the mean one. To doing this, just set these following options: --mean_frf false --set_frf true. Doing this you can run all your subject in one pipeline but you must to remove all the reverse-encoded b0. By default TractoFlow check if you have the reverse-encoded b0 for all your subjects. If not it will crash.



Hi @Steven,

Can you mark this thread as solved ? It helps sort the different issues.

Thank you in advance