Running fMRIPrep Docker

Dear all,

I have a question related to this as I cant get fmriprep-docker to run.
I work on Macos (mojava v.10.14.3) and I installed docker and phyton 3.7 anaconda. I installed Freesurfer and got the license.

I ran: $pip install --user --upgrade fmriprep-docker

Collecting fmriprep-docker
_ Using cached
Building wheels for collected packages: fmriprep-docker
_ Running bdist_wheel for fmriprep-docker … done_
_ Stored in directory: /Users/marloulasschuijt/Library/Caches/pip/wheels/e8/9a/6f/c78e0d9fc1ad4b9bea47071abe5dc8e6fa69aea38bd8d2956c_
Successfully built fmriprep-docker
Installing collected packages: fmriprep-docker
_ The script fmriprep-docker is installed in ‘/Users/marloulasschuijt/.local/bin’ which is not on PATH._
_ Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location._
Successfully installed fmriprep-docker-1.3.2

However when I run fmriprep-docker I keep getting the error “command not found”.
I changed the directory to the path’/Users/marloulasschuijt/.local/bin’ but still was not able to find fmri-prep docker. when I searcher for the programfiles manually I clicked on the program file and than this appeard:
iMac-van-Job:~ marloulasschuijt$ /Users/marloulasschuijt/.local/bin/fmriprep-docker ; exit;

Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

Downloading. This may take a while…

docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?.

See ‘docker run --help’.

Could not detect memory capacity of Docker container.

Do you have permission to run docker?


Saving session…

…copying shared history…

…saving history…truncating history files…


Deleting expired sessions…none found.

I am pretty new to all this, hope someone can help me out!


Hi @Marlou

Thank you for your question. It appears your fmriprep-docker is not on PATH, which is why you cannot run it directly from your command line globally. Is your docker running while you are trying to run fMRIPrep? It could also be under a different name than it may appear is being searched: I found it under fmriprep-docker. The program you are running may be the source files which could be why you are getting those errors.

Thank you,

Hi @Marlou, usually when I get the latter error message, it means I’m trying to run the Docker wrapper but don’t have Docker running (open the app --> on Mac OS, you’ll see the little whale icon at the top right of the screen. After this, you may need to click on the icon, select “Sign in”, and enter your Docker account credentials. You can also login through the command line).

I also had issues at first with fmri-docker: command not found. I have some documentation about how I addressed that problem here (under “Installation” in the fMRIPrep section):

Hope this helps,

1 Like