Singularity mounting issues

Hi mindboggle experts,
I am quite new to mindboggle and singularity, and I am trying to run mingboggle on HPC, and after successfully downloading the image and setting the environment like:


when I tried the run one subject, it printed out error message

WARNING: destination /home/xs266/scratch60/initial already in mount list: destination is already in the mount point list
WARNING: skipping mount of /home/x266/scratch60/initial: no such file or directory
WARNING: skipping mount of /home/xs266/scratch60/initial/jovyan: no such file or directory

Do you guys know what is causing this problem and how to solve it!

Thank you so much!

I consulted our HPC staff, and this is what they replied :

The problem with the command that they are suggesting (which I would love to discuss with them if they are available) is that /home/jovyan/work is not a path you can bind-mount to because singularity runs with your user permissions which cannot modify /home or /home/jovyan. Unfortunately you need to be able to point things at a path other than /home/jovyan/work for things to work on the cluster. If you have any open corresponance with the authors it’d be great if you asked them how best to change whatever is pointing to /home/jovyan/work .

Thank you for reporting on the cause of the issue! I’m afraid I’m not an expert in setting up containerized environments. @satra – Do you have any suggestions for resetting the mounting path?

It appears the automatic binding to $HOME can be disabled (called a “system-defined bind point”); however this may depend on the version of Singularity you have- Singularity is one of the fastest-changing softwares I’ve had experience with.

It can be toggled in the Singularity configuration file. From the guide:

The Configuration file can be found at $SYSCONFDIR/singularity/singularity.conf. The template in the repository is located at etc/singularity.conf.

Info on the system-defined bind points:

Info on how to toggle it off:

Please let me know if this works for you.