Syn-sdc not working with more recent fmriprep version

Hi,

I’ve noticed that when using fmriprep 1.5.3 susceptibility distortion is omitted even though my command contains --use-syn-sdc. If I use version 1.4.1, however, SDC is ran.

The command I submit is:

singularity run --cleanenv ${HOME}/singularity_images/fmriprep-1.5.3.simg \
    ${data_folder} ${postprocessed_folder}  \
    participant \
    --participant-label ${file} \
    --fs-license-file ${HOME}/license.txt \
    -w ${working_folder} \
    --use-syn-sdc \
    --skip-bids-validation\
    --ignore fieldmaps\
    --nthreads 4 \
    --omp-nthreads 4 \
    --mem_mb 20480 \
    -t rest \
    --fs-no-reconall 

I tried adding MNI152NLin2009cAsym to output spaces as suggested here FMRIPREP1.4.0 does not work using SyN distortion correction but that didn’t seem to help

Any advice appreciated!

Rob

Good catch. --use-syn-sdc now has no effect when --ignore fieldmaps is used. This is a bug, and I will report it.

Do you have fieldmaps you’re ignoring? If not, then you should be able to drop --ignore fieldmaps and get what you want. If not, you’ll need to wait for a fix or revert to an older version. 1.5.2 is the most recent version that should not exhibit this bug.

Hi @rob, can you try running with fMRIPrep 1.5.6? I pushed a quick fix that should resolve this.

Thanks I ran and received the error:

Node Name: fmriprep_wf.single_subject_507_wf.func_preproc_ses_B_task_rest_run_1_wf.syn_unwarp_report_wf.map_seg
Node Name: fmriprep_wf.single_subject_507_wf.func_preproc_ses_A_task_rest_run_1_wf.syn_unwarp_report_wf.map_seg

Just to confirm that I am also receiving this error on some (not all) subjects. I thought this was related to improper setup of field map parameters causing fmriprep to try and fall back to syn-sdc, but maybe I was wrong. I am currently re-running a subject that had this problem with fmriprep 1.5.5, and if the problem is still there will try 1.5.7.

P.s. We don’t typically need syn-sdc, we just produce it for comparison with field map sdc.

Just to give an update. I don’t see this exact error in v1.5.7 but there is a different problem still on the syn-sdc processing, as shown in another thread: