Tractoflow - Error 'Read_BIDS'

Hello everyone,

I am trying to run tractoflow but there is an error that I can’t find. I have already validate my BIDS structure thanks to the online validator and I don’t know why there is such issue.
My ubuntu terminal says :

Error executing process > ‘Read_BIDS (Read_BIDS)’

Caused by:
Process Read_BIDS (Read_BIDS) terminated with an error exit status (127)

Command executed:

scil_validate_bids.py Niftii tractoflow_bids_struct.json --readout 0.062

Command exit status:
127

Command output:
(empty)

Command error:
.command.sh: line 2: scil_validate_bids.py: command not found

Work dir:
/home/opheliemartinie/work/1d/bb1d06433e5d61b16612a6d800e795

Tip: view the complete command output by changing to the process work dir and entering the command cat .command.out

Thanks for anyone who could help me!..

How are you running Tractoflow?

Hi Steven,
I am running tractoflow thanks to this command :

nextflow run tractoflow/main.nf --bids ProjectFolder --dti_shells “2000” --fodf_shells “2000” -with-singularity tractoflow_2.1.1_650f776_2020-07-15.img -resume

I tried to change the path to access to my folder after the option --bids but it does not change the results…

Not sure what is causing the error, but one change you will want to make is including 0 in your shells arguments

I tried to change the shells arguments but nothing new happens neither…
Just to correctly understand the function, why changing the shells arguments could help? I am still a beginner with tractoflow so I am trying to understand all the arguments.

The shells argument won’t fix that error, but when you’re fitting the diffusion tensor (DTI) and fiber orientation distribution functions (fodf) you need to also include the b=0 images (in addition to the diffusion weighted images you’ve already specified). I’m guessing if the command couldn’t be found as specified in the error message, then maybe the singularity image did not load correctly. Can you confirm the singularity image exists at the path you’ve specified in your original command?

Oh okay I understand! Thanks!!
Yes the singularity image exist in this path and I have checked if I have permission access (as sudo etc…)