Trouble implementing fd and dvars spike threshold

fmriprep
#1

Hello! I’ve been having trouble using both “–fd-spike-threshold” and “–dvars-spike-threshold” in my fmriprep script. My error log tells me that --fd-spike-threshold, for example, is an unrecognized argument.

I’ve tried moving the order of my arguments, adjusting thresholds, etc. Has anyone else run into this issue?

This is the command I’ve tried running most recently (removing --dvars-spike-threshold, setting --fd-spike-threshold to 0.5):

fmriprep $bids_dir/ $other_dir/prepout participant -w $other_dir/prepwork --mem_mb 20000 --nthreads 8 --output-space fsaverage fsaverage5 fsnative template --fd-spike-threshold 0.5 --use-aroma --template MNI152NLin2009cAsym --participant-label P01

#2

Hi @kyliem21

Thank you for your message! Sorry to hear this is not working. What version of fMRIPrep are you running and what may you see passing --help?

Thank you,
Franklin

#3

Hi @franklin! I updated my version to 1.4.1, and the issue with spike thresholds seems to have resolved.

Thanks!