Unknown option `show-origin' with bidsmri2nidm using NIDM

Summary of what happened:

Running bidsmri2nidm to create a participants.json sidecar for my bids dataset.

Command used (and if a helper script was used, a link to the helper script or the command generated):

In a conda env i installed PyNIDM (pip install pynidm) and Datalad (pip install datalad), and an InterLex API key following David Keators ABCD-repronim slides here (https://youtu.be/-Y-3OBDZJgo?t=1722) and am working with a BIDS directory with what I think is a compliant participants.tsv file and a dataset_description.json

when I run bidsmri2nidm -d bids/ -bidsignore where bids/ is the folder within which my bids dataset is, I get this error:

datalad.runner.exception.CommandError: CommandError: 'git --git-dir=/dev/null config -z -l --show-origin' failed with exitcode 129 [err: 'error: unknown option `show-origin'

Hi @rahul-brito,

Does git config -h show that --show-origin is a expected argument? If you want to try ignoring that argument, you can install your own repo of Datalad, and change line 409 in datalad/config.py.


Nice point, git config -h does not show --show-origin is a expected argument.

I could try that, but Im going to wait to see if there’s a more supported option before trying any funny business

I would make sure git is updated (or maybe rolled back if the feature was taken out), as the option shows up for me (I have git version 2.39.2).

ah right. ok updating git with conda install git in my conda env seemed to solve it. It was using a very old version of git installed on the head node of my cluster