XCP_D band-pass filter does not work

Summary of what happened:

Dear community,
I am new to XCP-D and I am using it to compute connectivity matrix after preprocessing my data with fmriprep. As input to the XCP-D I use the AROMA image output of fmriprep. I would like to run the band pass filter (0.01-0.1) in XCP-D but when I check the denoised image (output of XCP-D) the algorithm applied only a high-pass filter. So, I can see in the power spectrum that in the denoised image were kept all the frequencies above 0.1 Hz.

I am thankful for your help.

Best wishes,

Command used (and if a helper script was used, a link to the helper script or the command generated):

singularity run --cleanenv xcp_d.simg \
    my_fmriprep_folder \
    my_output_folder \
    participant --participant-label sub-001 \
    --bids-filter-file BIDSfilter_xcpd.json \
    --smoothing 0 \
    -p acompcor \
    --lower-bpf 0.01 \
    --upper-bpf 0.1 \
    --min_coverage 0.8 \
    --fd-thresh 0 \
    --dcan-qc \
    --work_dir my_workdir_folder


XCP-D version 0.5

Environment (Docker, Singularity / Apptainer, custom installation):

I am using the singularity

Data formatted according to a validatable standard? Please provide the output of the validator:

The input data are in BIDS format as requested by fmriprep

Hi @Susanna and welcome to neurostars!

Can you reproduce the error in the most recent release (0.6.2)? Be sure to use a new working directory when you upgrade versions.


Hi @Steven,
Thanks a lot for your quick reply! I will try the most recent release as you suggested and give you an update.


@tsalo I see @Susanna is using acompcor. Does that disable bandpass filtering in favor of the DCT components?

@Steven it does not. I could be wrong, but I don’t think DCT will work for the low-pass element of the bandpass filter.

@Susanna once you run the new version, if the problem persists, can you share the full stdout and stderr logs with me? You should be able to DM them to me if you don’t want to post them in the topic.

@tsalo Sure! I will.

Thanks a lot for the help

@tsalo @Steven Sorry for the late reply. The update to the new version of XCP-D fixed the issue.
Thanks a lot for your help!