BIDS Validation hangs and is stuck on update to dataset

Summary of what happened:

I have been trying to update my dataset OpenNeuro to fix an EDF header error, but the BIDS validation gets stuck (for hours/days). I have verified that the dataset I am uploading is BIDS-compliant with the github BIDS validator. I have tried using the browser upload on Google Chrome and Safari, as well as the openneuro-cli, but to no avail. I’ve also deleted the files from the current version and reuploaded all of them to see if that would help, but I still just get the spinning “Validation Pending” message. I saw others have had this problem as well, but none of the suggested solutions worked for me (adding to the files, editing small files, fixing json files, etc.).

Command used (and if a helper script was used, a link to the helper script or the command generated):

Aside from the browser upload, I also tried the following using the openneuro cli (v4.22.0), but this didn’t make any difference when I went back to the browser.

openneuro upload --dataset ds004993 -i .


  • OpenNeuro browser upload
  • Macbook Pro running Ventura 13.4.1 (M2 Max chip)
  • Google Chrome Version 120.0.6099.234 (Official Build) (arm64)
  • Safari Version 16.5.2 (18615.
  • openneuro cli (v4.22.0)

Data formatted according to a validatable standard? Please provide the output of the validator:

This is a valid BIDS dataset using the online

30 Files, 305.11MB
3 - Subjects
2 - Sessions
Available Tasks
Available Modalities
This is a valid BIDS dataset!
Click to view details on BIDS specification
If you have any questions please post on Neurostars
The source code for the validator can be found here

Thanks for any suggestions you may have!

Hi Liberty,

This should be fixed now. Thanks for bringing it to our attention.


1 Like

Thanks Chris, I appreciate it! :smile:

Hey @effigies,

I am having the same issue after including the json files in the upload. We use dcm2niix to create json files and edited the ProtocolName and SeriesDescription. It goes through without the json files on OpenNeuro.