Does C-PAC support direct fieldmaps?

I am working with a collection of images that contains resting state acquisitions along with direct fieldmap files from a GE Discover 750 scanner as I believe are described by @mrjaemin and by the BIDS docs. Dcm2niix splits the fieldmap and magnitude volumes into two niftis with sidecars, and I rename them to _magnitude.nii.gz and _fieldmap.nii.gz. These are then successfully validated by bids-validator, and I hope/assume are also technically correct.

When I process these data with fMRIPrep 22.0.0, the final report shows me a B0 map and a distortion-corrected functional run, which gives me confidence I’ve set these files up correctly.

When I tried to run C-PAC without a configuration yml (default pipeline), it complained about missing phasediff data.

[!] C-PAC says: None of the listed resources are in the resource pool:

I then created a config.yml files and I’ve tried several configurations, but each thing I try fails differently. My latest attempt reports the following (first two lines repeated for each subject), then raises an exception.

[!] No scan parameter information found in your scan parameter configuration for the functional input file:
site: nyspi, participant: U22370, session: 15442, series: All

Traceback (most recent call last):
  File "/code/", line 807, in <module>
  File "/code/", line 367, in run_main
    main.main(args=sys.argv[sys.argv.index('--') + 1:])
  File "/usr/local/miniconda/lib/python3.7/site-packages/click/", line 697, in main
    rv = self.invoke(ctx)
  File "/usr/local/miniconda/lib/python3.7/site-packages/click/", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/local/miniconda/lib/python3.7/site-packages/click/", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/local/miniconda/lib/python3.7/site-packages/click/", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/local/miniconda/lib/python3.7/site-packages/click/", line 895, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/local/miniconda/lib/python3.7/site-packages/click/", line 535, in invoke
    return callback(*args, **kwargs)
  File "/code/CPAC/", line 352, in build
  File "/code/CPAC/utils/", line 1762, in run
  File "/code/CPAC/utils/", line 905, in get_BIDS_data_dct
  File "/code/CPAC/utils/", line 1618, in get_nonBIDS_data
  File "/code/CPAC/utils/", line 1100, in update_data_dct
ValueError: empty separator

From searching for information, it seems these GE fieldmaps are not the norm, but I don’t know how rare they are. Does CPAC 1.8.4 have the capability to do distortion correction with these files? Or, perhaps, do I need to feed distortion-corrected images to CPAC (assuming I’d then need to exclude fmap scans in config.yml)?

Thanks for any help.

EDIT: The first error was attempting to run the default C-PAC "run" pipeline. The second was while attempting to run the "cli -- utils data_config build" pipeline.