FMRI Prep and Slice Time Correction


#1

Hi NeuroStars,

I have provided slice timing information via json files when running fMRI prep. However, despite this, the html report states “Slice timing correction: Not applied” (see attached). Is there a way to ensure slice time correction is performed? Or am I doing something wrong?

Below I have attached a screenshot of the json file, html report, and the commands used when running fMRI Prep.

Cheers,
Thapa :slight_smile:


#2
  1. Please run the bids-validator on the input dataset and make sure there are no warnings concerning slice timeing.
  2. Please share the full HTML report (with figures which are in a separate folder).

#3

Hi Chris,

Thank you for your reply.

I’ve double checked my data with the BIDS validator ( https://1526-37161308-gh.circle-artifacts.com/0/root/web_version/index.html). Below are the steps I took:

  1. Ran the data via the BIDS validator, and got the following errors:

File names:

  1. After reading into the errors, I removed the underscore for the “_task-”

  1. I then ran the data through the BIDS validator again. While I was able to remove 2 errors, I still got the following 2 errors:

  1. I have tried renaming the files again based upon the BIDS validator document, but seem to get the same error as shown above.

BIDS_doc

  1. Further, fMRI Prep seems to recognise the data and run its analysis on data with or without the underscore removed. However, I get the same message “Slice timing correction: Not applied”

So, the questions I now have are:

i) How is fMRI Prep running it analysis on data that cannot be fully validated by the BIDS validator?

ii) Why am I getting a “Task_Name” error despite naming it following the BIDS doc.

iii) Lastly, does this error explain why fMRI Prep is not being able to run slice time correction?

Thank you,

Cheers,
Thapa


#4

Out of curiosity - why did you use this URL instead of http://bids-standard.github.io/bids-validator/ ?

It assumes input data is BIDS compatible, but never checks this assumption. In the next version, we will start running the validator as part of fmriprep.

This error concerns the content of the JSON files not the filenames. See https://bids-specification.readthedocs.io/en/latest/04-modality-specific-files/01-magnetic-resonance-imaging-data.html#required-fields

Nope. I would have to see the reports (please include figures wich are in a separate folder when shating the HTML file) to tell more.


#5

It looks like you’re using multi-echo data – is that correct, @TribikramT ?


#6

@ChrisGorgolewski: Thank you for your answers. Really appreciate your quick replies.

Re: URL vs clone from github - it was more about convenience as I came across the link (shared in the earlier post) in a previous post regarding BIDS validation. Is there a difference between the two? If yes, I am happy to cross-reference my data using the clone from github.

Re: fMRI Prep and BIDS validator: I wasn’t aware of this. Thank you for clearing this out. Yes, it would be awesome to include the BIDS validator as part of fMRI Prep.

Re Task Name error: Thank you for clarifying this too. I realised my previous JSON files had “ProtocolName” instead of “TaskName”. After changing this, the only error I get is “DATASET_DESCRIPTION_JSON_MISSING”

Result from BIDS validator

Link to figures: https://drive.google.com/drive/folders/1BQVibZ58rUZXv6djZQeNn1K71Vqu2Dgs?usp=sharing

@emdupre That is correct. I am using multi-echo data.

Once again, thank you for your help and replies.

Cheers,
Thapa


#7

Thanks @TribikramT - I will also need the HTML file.

@emdupre - is slice timing correction turned off for multi echo data?


#8

Yes, slice-time correction is not implemented in master for multi-echo. It is in #1296 !

Elizabeth


#9

Hi again,

Just in case you’re still encountering this issue @TribikramT , slice-time correction for multi-echo was implemented in 1.2.4 ! So I would recommend upgrading to the latest release :slight_smile:

Elizabeth


#10

@ChrisGorgolewski @emdupre Cool! Thank you for the update. Will give it a go :slight_smile: