fMRIPrep distortion correction issue hyperintensity in cerebellum

Hi all,

We are currently using fMRIPrep version 20.0.6 to preprocess our fMRI datasets (both resting-state and task-related). This works fine for nearly all data, but is causing an issue for 2 participants. fMRIPrep reports no errors, but the susceptibility distortion correction (based on topup) doesn’t look good and appears very dark on the html report and corresponding files. This seems to be related to a hyperintense signal in the cerebellum, which looks similar in both participants, but is not visible in the raw data. We have tried troubleshooting by simply rerunning, rerunning with T1-based distortion correction, rerunning in version 20.1.1 (the newest version on our server), but the issue remained. I have added screenshots of the raw data and susceptibility distortion output of one participant below. (I will add them as comments below since I am not yet allowed to share multiple screenshots in my post).

If anyone has an idea about what may be causing this issue, I would very much appreciate your help!
Kind regards,

Raw fMRI resting-state data

Data after distortion correction

Susceptibility distortion correction report

Report #2

Hi Amber,

Thank you this detailed report. First of all, I think FMRIPREP v20.2.6 was using 3dQwarp from AFNI and not topup from FSL, topup was introduced for FMRIREP v21.0.0 and later. Just to be clear, is FMRIPREP using the PEPOLAR method for SDC correction with the data you give?

Could you try with a later version of FMRIPREP (v22.0.2 for instance), with topup, to see if the same behavior occurs for those subjects? Also, you may want to try with the fieldmap-less option for this subject to see if you get a better result?

It could also be informative for us to know which FMRIREP command you used. To track down why SDC failed for these particular subject, you could also look at the temporary files (saved with the option -w) to see if you manage to pin-point at which stage the preprocessing failed for this particular subject.

Hi Julien,

Thank you for your quick reply! fMRIPrep indeed used the PEB/PEPOLAR method for SDC. And you are also correct about 3dQwarp being used. The following command was used:

We currently did not save the temporary files but will make sure to do so in the next try. I do not believe our server currently supports a newer version than 20.1.1, but I will look into this. I will also look into the fieldmap-less option and update in the post asap!

You may also want to try without the --fs-no-reconall flag, the use of this flag is somewhat discouraged, as discussed here

To use the fieldmap less option, this post will guide you:

Also be aware that the use of --use-syn-sdc option along with the --ignore fieldmaps option may not work with fmriprep v20 (due to a bug that was only corrected in fmriprep v22.0.2). You may need to use --bids-filter-file to filter out the fieldmap to use the field map-less option.

Cropping the lower part of the cerebellum also solved the issue. We attempted this because the hyperintense signal seemed to originate from this area (and we won’t be using it in our analyses). Thanks for the helpful suggestions Julien!

1 Like