Fmriprep html openning problem


After running frmriprep on one subject in my local PC I faced error.
Actually, the folder of output is ok and all of file is cerated in Anat and func

but when I wanted to open html file to see confound and other items
I faced this error:

Access to the file was denied

The file at /home/user/outputmp13/sub-mp0013.html is not readable.

It may have been removed, moved, or file permissions may be preventing access.

I faced the same error when I opened jupyter notebook, but now its fix(without doing any special things).

Any suggestion would be appreciate.
Best, Roqa


How are you trying to open the html?


Thank you so much for your answer.

like the last one that I did that
actually I had fmriprep on my linux and I worked with
but now because of the problem that I had by my Jupyter I uninstall and re install Linux and all the other software

I open the html by double click and opening by mozila firefox.

I appreciate your time and help

as you can see all the items have lock sign!

Can you see who has permission to those files? You can use the ls -l command.

total 196
-rw-r–r-- 1 root root 696 Sep 27 12:58 dataset_description.json
-rw-r–r-- 1 root root 49926 Sep 27 12:58 desc-aparcaseg_dseg.tsv
-rw-r–r-- 1 root root 49926 Sep 27 12:58 desc-aseg_dseg.tsv
drwxr-xr-x 2 root root 4096 Sep 27 09:22 logs
drwxr-xr-x 3 root root 4096 Sep 27 09:22 sourcedata
drwxr-xr-x 5 root root 4096 Sep 27 09:34 sub-mp0013
-rw-r–r-- 1 root root 74969 Sep 27 12:58 sub-mp0013.html

Are you the root user?

actually that a local laptop
and when I install Linux chose “/root” instead of “/”

Can you use the chmod command to change the permissions of the files?

chmod 777/output you mean?

you might need the -r flag to apply it recursively to the whole folder, but yes