Fmriprep license file issue

fmriprep

#1

Hi all

I got the following error when i tried to run fmriprep:

RuntimeError: Command:
mri_robust_template --satit --mov /scratch/work/fmriprep_wf/single_subject_78_wf/anat_preproc_wf/anat_template_wf/n4_correct/mapflow/_n4_correct0/sub-78_ses-01_T1w_ras_corrected.nii /scratch/work/fmriprep_wf/single_subject_78_wf/anat_preproc_wf/anat_template_wf/n4_correct/mapflow/_n4_correct1/sub-78_ses-02_T1w_ras_corrected.nii --inittp 1 --iscale --template sub-78_ses-01_T1w_ras_template.nii --subsample 200 --lta /scratch/work/fmriprep_wf/single_subject_78_wf/anat_preproc_wf/anat_template_wf/t1_merge/tp1.lta /scratch/work/fmriprep_wf/single_subject_78_wf/anat_preproc_wf/anat_template_wf/t1_merge/tp2.lta
Standard output:
$Id: mri_robust_template.cpp,v 1.54 2016/05/05 21:17:08 mreuter Exp $

–satit: Will estimate SAT iteratively!
–mov: Using /scratch/work/fmriprep_wf/single_subject_78_wf/anat_preproc_wf/anat_template_wf/n4_correct/mapflow/_n4_correct0/sub-78_ses-01_T1w_ras_corrected.nii as movable/source volume.
–mov: Using /scratch/work/fmriprep_wf/single_subject_78_wf/anat_preproc_wf/anat_template_wf/n4_correct/mapflow/_n4_correct1/sub-78_ses-02_T1w_ras_corrected.nii as movable/source volume.
Total: 2 input volumes
–inittp: Using TP 1 as target for initialization
–iscale: Enableing intensity scaling!
–template: Using sub-78_ses-01_T1w_ras_template.nii as template output volume.
–subsample: Will subsample if size is larger than 200 on all axes!
–lta: Will output LTA transforms
Setting iscale …
reading source ‘/scratch/work/fmriprep_wf/single_subject_78_wf/anat_preproc_wf/anat_template_wf/n4_correct/mapflow/_n4_correct0/sub-78_ses-01_T1w_ras_corrected.nii’…

GNU libc version: 2.23
ERROR: Systems running GNU glibc version greater than 2.15
require a newly formatted license file (it’s free). Please
download a new one from the following page:
http://surfer.nmr.mgh.harvard.edu/registration.html

Standard error:

Return code: 255

180118-00:31:02,125 workflow ERROR:
Node t1_merge failed to run on host cd0ecc6189b8.
180118-00:31:02,126 workflow ERROR:
Saving crash info to /scratch/out_fmriprep_071217/fmriprep/sub-79/log/20180117-134108_bd4215e2-7835-4bf2-b37f-5e9b7cdc0d2c/crash-20180118-003102-root-t1_merge-939ccd02-654c-432a-b612-722f93f79554.txt

The error is only happening for the subjects with more than one timepoint.
It seems the license file is not up to date. However, i downloaded a new file just recently and so it should be up to date.

The following command line was used to run fmriprep:

sudo docker run -v /home/ubuntu/projects/AN_project/INHIB:/data -v /home/ubuntu/projects/AN_project/INHIB:/scratch -v /home/ubuntu/projects/AN_project/license.txt -w /scratch poldracklab/fmriprep:latest /data /scratch/out_fmriprep_071217 participant -w /scratch/work --no-freesurfer --use-aroma --longitudinal --fs-license-file /home/ubuntu/projects/AN_project/license.txt

Any ideas what’s wrong?

Thank you.


Issues with GNU libc, freesurfer license in fmriprep
#2

quick guess, but I think with:
--fs-license-file /home/ubuntu/projects/AN_project/license.txt
The pathname has to be recognizable by the docker container, like with what you did with
-v /home/ubuntu/projects/AN_project/INHIB:/data
and specified the fmriprep input directory just by saying /data.

So if you would do something like
-v /home/ubuntu/projects/AN_project:/data instead of -v /home/ubuntu/projects/AN_project/INHIB:/data

and the input directory for the fmriprep command would look like:
/data/INHIB instead of /data
and the license file optionwould look like: --fs-license-file /data/license.txt instead of --fs-license-file /home/ubuntu/projects/AN_project/license.txt


#3

Further info: http://fmriprep.readthedocs.io/en/latest/installation.html#the-freesurfer-license


#4

Hi

Thank you for the comment and link. It seems to work fine now. Thank you.


#5

@silvano, can you provide the command that worked? I’m getting an almost identical issue as yours (ie brand new FS license but still being asked to get an up to date one due to GNU glibc) and have not had any success the last week or so. Thanks!

edit: Oh geez, I didn’t realize this was from last January, not this January!


#6

FYI: fMRIPrep Tutorial