Fmriprep memory issue

Hi!

I’m running fmriprep on a single subject with 2 tasks. Each task has around 900 volumes.
I specify an external disk with 2TB as a working directory. I also use --the low-mem flag. I also use 18Gb of RAM for the docker.
I also tried to run fmriprep for each task separately.
But no matter what I do, I run into memory issues. I get an error message about the broken process pool.

Do you have any idea what else can be done for this dataset?

Hello,

You can try uploading the data to Brainlife.io and running fmriprep on their servers.

Best,
Steven

It now always stops at
could not run node: fmriprep_wf.single_subject_pilot4_wf.anat_preproc_wf.surface_recon_wf.autorecon_resume_wf.autorecon_surfs

It also shows this error:
Standard error:
ln: failed to create symbolic link ‘rh.white.H’: Operation not supported
Return code: 1

I’m not sure anymore if it’s actually a memory issue

Is this on Brainlife or on your machine?

If on your machine, do you have read/write permissions on all relevant drives?

Why are you providing the low memory flag if you allow 18 gb of memory via docker access? We ran similar images (i.e., # of volumes) using the following----

   --n_cpus '12' \
    --omp-nthreads 8 \
    --mem 20GB \

I would give that a go and see what happens.

Their docs are also helpful—see here:

https://fmriprep.org/en/stable/faq.html#how-much-cpu-time-and-ram-should-i-allocate-for-a-typical-fmriprep-run