Fmriprep resamples bold images to another voxel dimension/orientation

@anna Update: Can you try using the poldracklab/fmriprep:orientation-fix image?

1 Like

crash-20190220-081323-root-slice_timing_correction-f26f3749-d953-4269-898b-e25edca2bb9a.txt (3.3 KB)

I started fmmriprep monday morning for some participants and it is still running, probably until friday evening, so I will try updating next week. However I ran the fslreoient2std on a single dataset and I got an fmriprep error log, because now the slice timing doesn’t match the right dimension anymore. I appended the errorlog. Is there a need for changing the dimension of the slice timing now?

Ah, good catch WRT slice timing. In any event, no. With the poldracklab/fmriprep:orientation-fix image you do not need to reorient your images prior to running fMRIPrep.

ok perfect thank you! So I will give this a try next week, when fmriprep finished running! Should the fix work well with the fieldmaps together, too? Or is there the need to change anything more for the fieldmaps?

1 Like

Yes, the fieldmaps shouldn’t have been affected by the bug; it was simply the resampling step that was affected.

1 Like

I finally tried your fix with a niworkflow repository (using the niworkflows corresponding to fmriprep 1.2.1 and changing the lines according to your fix) together with fmriprep 1.2.1 and it works!! Thanks a lot for helping and solving the problem!!

1 Like

We will be rolling out a new release with this patch soon. Thanks @anna for your patience :slight_smile:

thats great thank you!