Freesurfer mri_surf2surf error

Hi All,

I have a question regarding an error after running freesurfer with command recon-all -s ${subject_id} -sd /my/dir -parallel -qcache -all. Complete error log command is the following:

CMD mri_surf2surf --prune --s fsaverage --hemi rh --fwhm 25 --sval rh.w-g.pct.mgh.fsaverage.mgh --tval rh.w-g.pct.mgh.fwhm25.fsaverage.mgh --cortex

Thats weird error, because all necessary steps of recon-all are completed including stats and surf files.

Would be very appreciated if you share your opinion about this issue!

Hi!

We would need some extra info. Could you share the error, not just the command that failed? Its easier to debug what happened.

VictorM

Hi @slieped,

Here is a recon-all.log, you can find, there was several runs including local_gi computations, so please find first instance of recon-all error exit.recon-all_report.txt (1.8 MB)

I have been checking the log you send.

It doesnt seem an actual problem with the CMD you copied in the original post. The fact that it appears after that command, is that its the last line of recon-all.
It is kinda hard to track the different steps, since you run it in parallel. However, my guess, is that at the EARLY beggining, when freesurfer tried to get the dicom-to-nifty-to-mgh step, it detects several dicoms and some of them failed to be transform.

If you inspect line 104 of the .log file, you will see exactly this. Freesurfer tried to mri_convert some dicoms to 001.mgz, and it failed.
This might result into two things: 1) no idea at all what freesurfer processed or 2) you had a T1 AND another dicom-series, the T1 was converted correctly and Freesurfer run smoothly and finished without actual errors.

Try to re-run it with the T1 transformed to .nii.

MANAGED BY INCF