Mriqc: "One or more participant labels were not found in the BIDS directory" on HPC with singularity

I know people have run into similar issues before, but I can’t seem to figure it out. Interestingly, when I ran mriqc with the same dataset and version 0.16.1 I did not get this error, but now I am using v23.0.0.

When I run mriqc with the below script I get the below error. I am running on a linux hpc. I isolated the problem to running the script on one subject and seeing the error e.g.:

singularity run -e -B /om2 
-B /om2/scratch/Thu/rfbrito/mriqc_work/voice893:/workdir 
-B /om2/scratch/Thu/rfbrito/bids:/input:ro 
-B /om2/scratch/Thu/rfbrito/bids/derivatives/mriqc:/out 
/om2/user/rfbrito/containers/imaging/mriqc-032423.sif /input /out participant --participant_label voice893 -w /workdir --nprocs 16 --omp-nthreads 8

When I do this, I get this error:

mriqc: error: One or more participant labels were not found in the BIDS directory: voice893

If I go into the container shell with the same bindings e.g.:

singularity shell -e -B /om2 -B /om2/scratch/Thu/rfbrito/mriqc_work/voice893:/workdir -B /om2/scratch/Thu/rfbrito/bids:/input:ro -B /om2/scratch/Thu/rfbrito/bids/derivatives/mriqc:/out /om2/user/rfbrito/containers/imaging/mriqc-032423.sif

and then I do

ls /input


ls /om2/scratch/Thu/rfbrito/bids

I can see my full bids directory with a folder sub-voice893. Note that if I run the command but use sub-voice893 instead of voice893 for --participant-label it still throws this error (I removed the sub- bit because some other posts I saw suggested that).

In my mind, my bindings are good and somehow its not seeing what it should? Anyways, appreciate any help!


Interestingly, it looks like 0.16.1 (the version that worked for me): " This PR improves BIDS Derivatives compliance, fixes an issue with reading datasets with subjects of the form sub-sXYZ

from: Releases · nipreps/mriqc · GitHub

Should be fixed in 23.0.1, out today.

1 Like