OSError: [Errno 28] No space left on device - templateflow?

I try to run fmriprep but i get the “OSError: [Errno 28] No space left on device”, towards the end of preprocessing a subject. The preproc runs for some time but after a while i get this error.

Notably, fmriprep was running before and I preprocessed the 2nd run; now I want to run the preproc for the 1st run in this dataset.

After this error I tried to export the home/.cache/templateflow (see code below) but still I get the same erorr.

I got these ideas from;

Please note:
I have set my workingdir & have available space. Our HPC has recently an SSL issue i imagine this may be related.(?) i suspect that we have SSL certificate issue and the system doesnt now download anymore the template flow (before I didnt export any templateflow path but code worked!)

Please help me solve this issue. Any suggestion?

I run:

export SINGULARITYENV_TEMPLATEFLOW_HOME=/home/iliopoul/.cache/templateflow


singularity --verbose  run -B /storage/users -B ${TEMPLATEFLOW_DIR}:/opt/templateflow /usr/local/bin/fmriprep-20.2.6.simg $bids_root_dir $out_dir participant \
--participant-label $subj \
--bids-filter-file /storage/users/iliopoul/PHD/data/bids_filter_memtrain2_run1.json \
-w $workdir \
--md-only-boilerplate \
--fs-license-file /storage/users/iliopoul/fs_license.txt \
--fs-no-reconall \
--output-spaces MNI152NLin2009cAsym:res-2 \
--verbose \
--stop-on-first-crash \
-t itemobject \
--write-graph \