Upgrading datalad to 0.15.0 using pip worked fine, enabling the dry-run option.
When I run without dry-run now, I get an error about an outdated git-annex version
u0027997@gbw-s-labgas01:/data/proj_discoverie$ datalad run -m "run KUL_dcm2bids.sh on sub-KUL005" -i "sourcedata/sub-KUL005" -o "BIDS/*" "KUL_dcm2bids.sh sourcedata/sub-KUL005 -p KUL005 -c study_config/sequences.txt -v"
[INFO ] Making sure inputs are available (this may take some time)
[ERROR ] OutdatedExternalDependency(No working git-annex installation of version >= 8.20200309. Visit http://handbook.datalad.org/r.html?install for instructions on how to install DataLad and git-annex… You have version 8.20200226) (OutdatedExternalDependency)
How shall I upgrade this?
Does not seem to work using
sudo apt-get upgrade or
git annex upgrade in the repo? I also adapted git config based on upgrades
git config annex.autoupgraderepository true
I tried the following then
u0027997@gbw-s-labgas01:~$ sudo apt-get install git-annex
Reading package lists… Done
Building dependency tree
Reading state information… Done
git-annex is already the newest version (8.20200226-1).
git-annex set to manually installed.
The following packages were automatically installed and are no longer required:
- libllvm11 libpython2-stdlib linux-headers-5.4.0-80 linux-headers-5.4.0-80-generic linux-image-5.4.0-80-generic linux-modules-5.4.0-80-generic linux-modules-extra-5.4.0-80-generic python2 python2-minimal shim*
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
The output reads “git-annex set to manually installed”, not sure whether this is a problem for datalad or any other applications using git-annex?
As far as I understand it, the problem seems to be that the version of git-annex that is installed on my Ubuntu 20.04.3 system while installing datalad (probably just using
sudo apt-get install datalad as per these instructions from the handbook, rather than using pip) is not the most recent version, and that apt-get fails to update to more recent versions?