Problems installing FSL

Hi NeuroStars,

I’m trying to install fsl on a HPC but it fails few minutes into the installation. Could you advise which version to choose and if there’s any specific flags to use to compensate for no root privileges?

Command used

python # installed into scratch
# also tried with python2 and --conda

Part of the log file (with the error):
09:23:56 [stderr]: # >>>>>>>>>>>>>>>>>>>>>> ERROR REPORT <<<<<<<<<<<<<<<<<<<<<<
09:23:56 [stderr]:
09:23:56 [stderr]: Traceback (most recent call last):
09:23:56 [stderr]: File “/mnt/shared/scratch/kmarians/apps/fsl/lib/python3.10/site-packages/conda/”, line 17, in call
09:23:56 [stderr]: return func(*args, **kwargs)
09:23:56 [stderr]: File “/mnt/shared/scratch/kmarians/apps/fsl/lib/python3.10/site-packages/conda_env/cli/”, line 56, in do_call
09:23:56 [stderr]: exit_code = getattr(module, func_name)(arguments, parser)
09:23:56 [stderr]: File “/mnt/shared/scratch/kmarians/apps/fsl/lib/python3.10/site-packages/conda/notices/”, line 124, in wrapper
09:23:56 [stderr]: return func(*args, **kwargs)
09:23:56 [stderr]: File “/mnt/shared/scratch/kmarians/apps/fsl/lib/python3.10/site-packages/conda_env/cli/”, line 143, in execute
09:23:56 [stderr]: result[installer_type] = installer.install(prefix, specs, args, env)
09:23:56 [stderr]: File “/mnt/shared/scratch/kmarians/apps/fsl/lib/python3.10/site-packages/mamba/”, line 155, in mamba_install
09:23:56 [stderr]: transaction.fetch_extract_packages()
09:23:56 [stderr]: RuntimeError: Resource temporarily unavailable
09:23:56 [stderr]:
09:23:56 [stderr]: $ /home/kmarians/scratch/apps/fsl/bin/mamba update -p /home/kmarians/scratch/apps/fsl -f /tmp/tmpypxrahjp/fsl-
09:23:56 [stderr]:
09:23:56 [stderr]: environment variables:
09:23:56 [stderr]: CIO_TEST=
09:23:56 [stderr]: CONDA_AUTO_UPDATE_CONDA=false
09:23:56 [stderr]: CONDA_ROOT=/mnt/shared/scratch/kmarians/apps/fsl
09:23:56 [stderr]: CURL_CA_BUNDLE=
09:23:56 [stderr]: LD_LIBRARY_PATH=/opt/slurm/latest/lib64
09:23:56 [stderr]: LD_PRELOAD=
09:23:56 [stderr]: MANPATH=/opt/slurm/latest/share/man/:/opt/slurm/latest/share/man/:/opt/slurm/l
09:23:56 [stderr]: atest/share/man/::
09:23:56 [stderr]: MODULEPATH=/etc/scl/modulefiles:/etc/scl/modulefiles:/etc/scl/modulefiles:/usr/sh
09:23:56 [stderr]: are/Modules/modulefiles:/etc/modulefiles:/usr/share/modulefiles
09:23:56 [stderr]: PATH=/opt/openmpi/latest/bin:/opt/slurm/latest/bin:/mnt/shared/apps/guppy/4
09:23:56 [stderr]: .2.2:/mnt/shared/apps/aspera/3.9.2/bin:/mnt/cluster/scripts:/mnt/share
09:23:56 [stderr]: d/scratch/kmarians/apps/conda/bin:/opt/openmpi/latest/bin:/opt/slurm/l
09:23:56 [stderr]: atest/bin:/mnt/shared/apps/guppy/4.2.2:/mnt/shared/apps/aspera/3.9.2/b
09:23:56 [stderr]: in:/mnt/cluster/scripts:/mnt/shared/scratch/kmarians/apps/conda/bin:/h
09:23:56 [stderr]: ome/kmarians/.local/bin:/home/kmarians/bin:/opt/openmpi/latest/bin:/op
09:23:56 [stderr]: t/slurm/latest/bin:/usr/share/Modules/bin:/mnt/shared/apps/guppy/4.2.2
09:23:56 [stderr]: :/mnt/shared/apps/aspera/3.9.2/bin:/mnt/cluster/scripts:/mnt/shared/sc
09:23:56 [stderr]: ratch/kmarians/apps/conda/condabin:/mnt/shared/scratch/kmarians/apps/c
09:23:56 [stderr]: onda/bin:/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin
09:23:56 [stderr]: REQUESTS_CA_BUNDLE=
09:23:56 [stderr]: SSL_CERT_FILE=
09:23:56 [stderr]:
09:23:56 [stderr]: active environment : None
09:23:56 [stderr]: user config file : /home/kmarians/.condarc
09:23:56 [stderr]: populated config files : /mnt/shared/scratch/kmarians/apps/fsl/.condarc
09:23:56 [stderr]: /home/kmarians/.condarc
09:23:56 [stderr]: /home/kmarians/scratch/apps/fsl/.condarc
09:23:56 [stderr]: conda version : 23.11.0
09:23:56 [stderr]: conda-build version : not installed
09:23:56 [stderr]: python version :
09:23:56 [stderr]: solver : libmamba (default)
09:23:56 [stderr]: virtual packages : __archspec=1=skylake_avx512
09:23:56 [stderr]: __conda=23.11.0=0
09:23:56 [stderr]: __glibc=2.28=0
09:23:56 [stderr]: __linux=4.18.0=0
09:23:56 [stderr]: __unix=0=0
09:23:56 [stderr]: base environment : /mnt/shared/scratch/kmarians/apps/fsl (writable)
09:23:56 [stderr]: conda av data dir : /mnt/shared/scratch/kmarians/apps/fsl/etc/conda
09:23:56 [stderr]: conda av metadata url : None
09:23:56 [stderr]: channel URLs : public/linux-64
09:23:56 [stderr]: public/noarch
09:23:56 [stderr]: conda-forge/linux-64
09:23:56 [stderr]: conda-forge/noarch
09:23:56 [stderr]: package cache : /home/kmarians/scratch/apps/fsl/pkgs
09:23:56 [stderr]: envs directories : /mnt/shared/scratch/kmarians/apps/fsl/envs
09:23:56 [stderr]: /home/kmarians/.conda/envs
09:23:56 [stderr]: platform : linux-64
09:23:56 [stderr]: user-agent : conda/23.11.0 requests/2.31.0 CPython/3.10.13 Linux/4.18.0-513.11.1.el8_9.0.1.x86_64 rocky/8.9 glibc/2.28 solver/libmamba conda-libmamba-solver/23.12.0 libmambapy/1.5.5
09:23:56 [stderr]: UID:GID : 896600222:896600222
09:23:56 [stderr]: netrc file : None
09:23:56 [stderr]: offline mode : False
09:23:56 [stderr]:
09:23:56 [stderr]:
09:23:56 [stderr]: An unexpected error has occurred. Conda has prepared the above report.
09:23:56 [stderr]: If you suspect this error is being caused by a malfunctioning plugin,
09:23:56 [stderr]: consider using the --no-plugins option to turn off plugins.
09:23:56 [stderr]:
09:23:56 [stderr]: Example: conda --no-plugins install
09:23:56 [stderr]:
09:23:56 [stderr]: Alternatively, you can set the CONDA_NO_PLUGINS environment variable on
09:23:56 [stderr]: the command line to run the command without plugins enabled.
09:23:56 [stderr]:
09:23:56 [stderr]: Example: CONDA_NO_PLUGINS=true conda install
09:23:56 [stderr]:
09:23:58 [stderr]: error libmamba Error when extracting package: std::bad_alloc
09:23:58 [stderr]: terminate called after throwing an instance of ‘std::bad_alloc’
09:23:58 [stderr]: what(): std::bad_alloc
09:24:00 206:
ERROR occurred during installation!
09:24:00 206: This command returned an error: /home/kmarians/scratch/apps/fsl/bin/mamba env update -p /home/kmarians/scratch/apps/fsl -f /tmp/tmpypxrahjp/fsl-

09:24:00 File “/mnt/shared/scratch/kmarians/apps/FSL/”, line 2760, in handle_error
File “/mnt/shared/scratch/kmarians/apps/FSL/”, line 2875, in main
File “/mnt/shared/scratch/kmarians/apps/FSL/”, line 2138, in install_fsl, cmd,
File “/mnt/shared/scratch/kmarians/apps/FSL/”, line 1586, in run
return process_func(admin=self.need_admin,
File “/mnt/shared/scratch/kmarians/apps/FSL/”, line 1056, in monitor_progress
raise RuntimeError('This command returned ’ …

(happy to include the entire log file if that helps)

Hi @km345, this looks like some sort of a system issue - how much RAM does your system have, and how much free disk space do you have in your scratch folder? FSL needs over 10GB of space when installed.

Hi @paulmccarthy, the head node has 6 Gb of RAM but I now requested a worker node with 32 Gb of RAM. Not sure how much disk space there is but it should not be a problem on a HPC. With 32 Gb RAM the installer fails at 6% with an error:
ERROR occurred during installation! [Errno 2] No such file or directory: '/home/kmarians/scratch/apps/fsl/pkgs/fsl-data_first_models_317_bin-2006.0-0.tar.bz2'

Can you share the log file?

I would confirm with your IT team how much storage space you have available - on a HPC it is common for per-user/group storage limits to be enforced.

Thanks @paulmccarthy, please see the log file. I am pretty certain that there is no storage limit in my scratch - I was always able to install software and download large files (including most recently many thousands fMRIs to be used with FSL).
fsl_installation_20240226172345.txt (184.6 KB)

Ok, I’ll trust that you have enough space. We have just released a new version of FSL - would you mind trying again (you should be able to simply re-run the same script)?

What kind of file system are you installing FSL to? It appears to be a network file system of some sort.

Hi Paul,

For some reason I am also having issues downloading FSL? I have attached the log file

Any help much appreciated! I downloaded but cannot seem to get the installer to work

Hi @Jigi_Moudgil-Joshi, it looks like the miniconda installer file is not being downloaded correctly (this seems to be the case in both of the log files that you uploaded). I’m not sure why, as going by the download timings in the log file, your internet connection appears to be quite fast - how are you connecting to the internet?

In any case, could you try downloading this file:

And then in a terminal run this command to calculate its checksum:

shasum -a 256 ~/Downloads/

The result should be:


If the checksum matches, you can try running the with this miniconda installer:

python --miniconda ~/Downloads/

Thank you so much - will give this a try later today

Using a 5G hub I have at home… would this impact anything

All sorted! Thank you so so much

1 Like

Hi Paul,

When I went to go and download the unix dataset for practice from the website, the response was this:

Hello, I recently purchased a new MacBook Air (M3, Sonoma 14.4.1) and have tried to install FSL with no success (I have installed FSL on previous machines with no problem). The “Installing FSL into …” step keeps stalling at 93%, and then I get the following error:

ERROR occurred during installation!
This command returned an error: /Users/User/fsl/bin/conda env
update -p /Users/User/fsl -f /private/var/folders/hh/p779zgr17tb91xm578k
Removing failed installation directory /Users/User/fsl
FSL installation failed!
Please check the log file - it may contain some more information to
help you diagnose the problem:

I’ve tried downloading the installer from the link recently supplied, and ran the command that seem to work for others (python --miniconda, but no success. Any suggestions?

Hi @David_F, have you checked the contents of the log file, as the error message suggests?

I did, but unfortunately don’t understand it. Can access the log here in case it’s helpful (won’t let me paste)?: Dropbox - fsl_installation_20240514010933.log - Simplify your life

Are you able to share a copy of the log file where you ran without any additional arguments? Passing an alternate miniconda installer should no longer be necessary.

Hi @David_F, actually I think there has been a change to conda which has broken FSL installations. Can you try re-running the script like this (don’t specify an alternative miniconda installer):


and see if that allows the installation to succeed?

I get a permissions issue with that:

zsh: permission denied: ./

Am I missing something simple?

Sorry, I meant something like the following (using whatever python you used to run the installer previously):


That works, thank you!

1 Like

keep getting this error…tried solving it with some suggestions I found online but nothing seems to work