Pydicom error during FEAT PPI analysis

I’m using FEAT to run a PPI analysis and am getting a weird, fatal error suggesting pydicom is out of date even though I am using the most updated version. Has anyone seen this before? Do I need to downgrade or something? Does anyone know which versions of pydicom are compatible with FEAT?

/bin/cp /bcdlab/CURforDAD/Graham_scripts/design.fsf design.fsf

/usr/local/fsl/bin/feat_model design

mkdir .files;cp /usr/local/fsl/doc/fsl.css .files;cp -r /usr/local/fsl/doc/images .files/images

/usr/local/fsl/bin/fsl_sub -T 10 -l logs -N feat0_init   /usr/local/fsl/bin/feat /bcdlab/CURforDAD/HC_IAM/1001/V1/Data/TASK_PPI.feat/rlaHippo_PPI_analysis++.feat/design.fsf -D /bcdlab/CURforDAD/HC_IAM/1001/V1/Data/TASK_PPI.feat/rlaHippo_PPI_analysis++.feat -I 1 -init
101870

/usr/local/fsl/bin/fsl_sub -T 30 -l logs -N feat2_pre -j 101870  /usr/local/fsl/bin/feat /bcdlab/CURforDAD/HC_IAM/1001/V1/Data/TASK_PPI.feat/rlaHippo_PPI_analysis++.feat/design.fsf -D /bcdlab/CURforDAD/HC_IAM/1001/V1/Data/TASK_PPI.feat/rlaHippo_PPI_analysis++.feat -I 1 -prestats
102016

/usr/local/fsl/bin/fsl_sub -T 62 -l logs -N feat3_film -j 102016  /usr/local/fsl/bin/feat /bcdlab/CURforDAD/HC_IAM/1001/V1/Data/TASK_PPI.feat/rlaHippo_PPI_analysis++.feat/design.fsf -D /bcdlab/CURforDAD/HC_IAM/1001/V1/Data/TASK_PPI.feat/rlaHippo_PPI_analysis++.feat -I 1 -stats
102120

/usr/local/fsl/bin/fsl_sub -T 119 -l logs -N feat4_post -j 102120  /usr/local/fsl/bin/feat /bcdlab/CURforDAD/HC_IAM/1001/V1/Data/TASK_PPI.feat/rlaHippo_PPI_analysis++.feat/design.fsf -D /bcdlab/CURforDAD/HC_IAM/1001/V1/Data/TASK_PPI.feat/rlaHippo_PPI_analysis++.feat -poststats 0 
zstat1 zstat10 zstat2 zstat3 zstat4 zstat5 zstat6 zstat7 zstat8 zstat9
/home/grw201/.local/lib/python3.7/site-packages/dicom/__init__.py:53: UserWarning: 
This code is using an older version of pydicom, which is no longer 
maintained as of Jan 2017.  You can access the new pydicom features and API 
by installing `pydicom` from PyPI.
See 'Transitioning to pydicom 1.x' section at pydicom.readthedocs.org 
for more information.

  warnings.warn(msg)
    while executing
"if { [ catch {

for { set argindex 1 } { $argindex < $argc } { incr argindex 1 } {
    switch -- [ lindex $argv $argindex ] {

	-I {
	    incr arginde..."
    (file "/usr/local/fsl/bin/feat" line 312)

FATAL ERROR ENCOUNTERED:
COMMAND:
/usr/local/fsl/bin/fsl_sub -T 119 -l logs -N feat4_post -j 102120  /usr/local/fsl/bin/feat /bcdlab/CURforDAD/HC_IAM/1001/V1/Data/TASK_PPI.feat/rlaHippo_PPI_analysis++.feat/design.fsf -D /bcdlab/CURforDAD/HC_IAM/1001/V1/Data/TASK_PPI.feat/rlaHippo_PPI_analysis++.feat -poststats 0 
ERROR MESSAGE:
child process exited abnormally
END OF ERROR MESSAGE

MANAGED BY INCF