Running only functionals

fmriprep
#1

I have two questions about the defaults in the workflow:

  1. If the anatomical preprocessing crashes will the functional workflow still run?
  2. If the anatomical preprocessing crashes at a certain step, when it is rerun will the preprocessing resume at that step or start over?
  3. Is there a flag to run only functionals? (or, will the anatomical wf be skipped if the preprocessing has been run already?)
#2

Parts of the functional workflow that do not depend on the outputs of the structural workflow will still run.

Yes, but only if you reuse the same working directory (-w option).

There is no such flag, but if you use the same working directory the previously computed outputs will be reused.

If FMRIPREP is crashing for you please report a bug here: https://github.com/poldracklab/fmriprep/issues

#3

Is it possible to run only the functional workflow if there are no anatomical images or poor-quality anatomical images? I was going to build in a flag because there have been multiple requests for a pipeline that only does functional runs in my lab.

#4

@mcsnyder Not as written. However, several of the functional subworkflows (BOLD reference estimation, slice-timing correction, head motion correction, fieldmap-based susceptibility distortion correction) do not use anatomical inputs. With a little work, these could be separated from coregistration and resampling. And portions of the confounds workflow do not require anatomical images (or BOLD series resampled in alignment with anatomical images).

Unfortunately, I don’t think we’re going to be able to devote much time to this in the near future, but we would be willing to consider a pull request that accomplishes this separation.

#5

Ok I’ll start working on it on my local copy.

I have one more question-- it seems that the functional pipeline won’t run if there are no T1w images at all-- is this fixed by one of the flags?

#6
#7

Hello, I wanted to know if there had been any progress on the issue discussed here. Is anyone still working on that front?

In my current sample, I have one participant who did not complete the whole scanning session. As a result, I only have the functional sequence. Preprocessing this run separately without T1 reference (mostly despike, motion correction, normalization) is relatively easy. However, I would not end up with the same confound file as in fmriprep. What would be the key steps needed to obtain similar confounds for future analysis?

#8

I think in the latest versions (since 1.4(?)) it is possible to specify the native EPI as the desired output space. The option is:
“–output-spaces func”.

However, I previously ran into a bug doing this, and I needed to specify an additional template to get around it (see my previous issue Error in "native" EPI space processing (--output-spaces func))

Perhaps try the “–output-spaces func” option and see how you go…

Dror

#9

Thanks Dror, I will definitely try this!