Standard templates mismatch in fsl and fmriprep (and its effect on ROI analysis)

Hi all,
I would like to ask a question related to the old thread posted in here, since I think I am running into a similar problem: Parcellation for MNI152NLin2009cAsym?

I ran preprocessing with fmriprep with the template MNI152NLin2009cAsym, and now I want to extract a ROI in fsl using an atlas on fsl’s standard template (MNI152_T1_2mm_brain). I realized that the coordinates of the two templates are not exactly the same. Because of that- when I try to examine the cope images of my subjects within the mask I created in fsl, I get the following error: “Error - mask size doesn’t match any of the images in the FEAT directory”. Note: I did the mask with the Harvard oxford atlas, which, to my understanding, is the one corresponding to fmriprep.

From the quoted thread, it seems like it was a problem in the past. However, now there is a way to download a suitable template to the one used in fmriprep, and then use it in fsl for the masking. If so, how exactly can I do that?

Thank you very much

  • List item

A quick answer: FSL is using a different template: MNI152NLin6Asym.

More details here:

In if you want to have your preprocessed data in that space, you could use --output-spaces MNI152NLin6Asym in your fmriprep command.

1 Like

Thank you! It worked! (I now have other problems, but at least now the coordinates are the same)