BIDSValidation Error after Updating fMRIPrep

Summary of what happened:

Command used (and if a helper script was used, a link to the helper script or the command generated):


Environment (Docker, Singularity, custom installation):

Data formatted according to a validatable standard? Please provide the output of the validator:

Relevant log outputs (up to 20 lines):

Screenshots / relevant information:


I am running fMRIPrep on multiecho fMRI data using singularity and have the follwoing issue: to use the --me-output-echos flag, I updated the fMRIPrep from v20.2.0 to v22.1.1. Without including the --me-output-echos I successfully ran my script on the same data but while using the fMRIPrep updated vesrion (22.1.1), I get the “BIDSValidationError: ‘dataset_description.json’ is missing from project root”. I checked the previous questions and performed the following checks:

  1. Successfully re-validated the directory with bidsvalidator v1.9.7.
  2. Checked the BIDS folder for the existance of the ‘dataset_description.json’ file and made sure that the .json file is not in the bidsignore (the only existing thing in bidsignore was bidsvalidator.out).
    For further inoformation, I have attached the fmriprep output error as fmriprep_error file.

Thank you very much!!
fmriprep_error.txt (1.5 KB)

I moved this issue to software support and added the boilerplate above your original post. Please provide the requested details.

Thank you very much for your reply, please find the required documents and info as follows:

Summary of what happend:
I am preprocessing multi-echo resting state fMRI data, and I intend using tedana for that. When using fmriprep version 20.2.0 without --me-output-echos flag on, there is no error and the software succefully preprocess the BOLD images (attached as fmriprep_output_v20.2.0), but when using the newer version of the fMRIprep (v22.1.1) with --me-output-echos flag on, I recieve bidsvalidator error as attached (fmriprep_output_v22.1.1). I have also included --skip_bids_validation in my commands.

I have only applied the command for now on only two participants that is why there is only two entry in each tsv file (attached here as txt files).

Command used: prep_v20_2_0.txt (2.8 KB) and prep_v22_1_1.txt (2.8 KB).

The execution command: sbatch --array=1-$(( $( wc -l /home/javan/scratch/multi_prep/test/script/me/version/participants_all_NAV2_id.tsv | cut -f1 -d' ' ) - 1 ))%20 /home/javan/scratch/multi_prep/test/script/me/version/prep_v20_2_0.sbatch

Link to the helper script or the command generated:

Version: fMRIprep v22.1.1 & v20.2.0, BIDSvalidator v1.9.7

Environment: Singulairty

Output of the validator: Validator_output.txt (6.0 KB)

Relevant log outputs:
fmriprep_output_v20_2_0.txt (2.6 KB)
fmriprep_output_v22_1_1.txt (1.6 KB)

The tsv files used in the command:
participants_all_NAV2_id.txt (42 Bytes)
participants_all_NAV2_ses.txt (30 Bytes)

Highly appreciate your guidance!!

Hi @AJavan,

  1. Your prep_v22_1_1.txt file is using the 20.2.0 image, are you sure you attached the right file? Also, 20.2.0 is not the most recent version of the LTS branch (as of right now, that is 20.2.7)
  2. --fs-no-reconall is not recommended (FreeSurfer tends to improve quality of spatial normalization).
  3. You bind -B /project/ctb-villens/dataset/PreventAD_2019-2020/mri/bids/sub-${SUBJECT}/ses-${BOLDPATH}/:/source_bids:ro. This is not correct. In your script, source_bids should be linked with the BIDS root directory (in your case, presumably /project/ctb-villens/dataset/PreventAD_2019-2020/mri/bids/)


Hi Steven,

Thank you very much for your reply, I implemented your suggestions and it worked (the mounting of the sorce directory was the issue and I changed it to the parent bids directory which worked). I just wanted to make sure that the preprocessing is successfully completed and then reply.

Regarding the commands attached, sorry there was a mistake in the naming of the files I ulpoaded here. Since I needed to copy the commands from a bash script and then upload them as txt here, I made a mistake in the naming of them but the original script vesrions were correct.

I also added the FreeSurfer for a better spatail normalization.

Highly appreciate your time and guidance,