Fmriprep missing the confounds tsv for run

fmriprep
fmri

#1

Hi,

I used fmriprep to preprocess some data. I have 2 runs in this study. The job completed, but I’m missing the confounds tsv for run 2 in the directory.

My current output in my functional folder of the subject has all of these files

sub-004_task-ec_run-01_bold_space-MNI152NLin2009cAsym_preproc.nii.gz
sub-004_task-ec_run-01_bold_space-MNI152NLin2009cAsym_brainmask.nii.gz
sub-004_task-ec_run-01_bold_confounds.tsv
sub-004_task-ec_run-02_bold_space-MNI152NLin2009cAsym_brainmask.nii.gz
sub-004_task-ec_run-02_bold_space-MNI152NLin2009cAsym_preproc.nii.gz

but there is no confounds tsv.

Does anyone have any suggestions?


#2

Did it run to completion without errors? Could you share the HTML report?


#3

I’m not 100% sure it ran to completion. I checked my jobs and one is still running, but I submitted other jobs around that same time that should have taken much longer than this job so I don’t think it’s this. I have an error and output file. The error file only mentions that the root directory I set for my preprocessing output is not “valid”, but the other outputs are in that directory. I ran fmriprep on a different set of data and it worked perfectly, but this dataset did not give me that confounds file for run 2.


#4

I noticed there was no html file so I reran the job and fmriprep worked this time. Strange since I didn’t change anything