Fmriprep - more distorted images after fmap correction

hi everyone, we are using fmriprep for the first time and have encountered some difficulties regarding the susceptibility correction by applying our field map. The unwarped images seem to be more distorted after performing the susceptibility distortion correction on the EPI. We are using a phase-difference map (+2 magnitude images).
Our first guess was that fmriPrep uses the wrong phase encoding direction. However, in our _phasediff.json and _bold.json, the parameter PhaseEncodingDirection is set to β€˜j-β€˜, which matches the anterior-posterior phase encoding direction of our sequences.

Maybe some of you had encountered a similar problem at some point and could help with some advice.

Thank you very much for your help in advance!

1 Like

Hi,

Did you get your images from a GE scanner by any chance? If so, this discussion (fMRIPrep 20.2.3 directly measured B0 map SDC correction created worse functional images) might be helpful.

Best,
Steven

Dear Steven, thank you very much for your reply. The images were obtained from a Siemens scanner. Nevertheless, I have tried to change the PhaseEncodingDirection to β€˜j’ in order to see whether this might result in a better correction. The correction is different but not better. This seems not to be the source of the problem. Btw, we have the same issue with all of our subjects. I have checked consistency in units (although I suppose, it would have been a much worse output if time units were inconsistent).
I don’t know whether it helps, but I have attached the images of the applied fmap corrections for both direction settings.

Best
Diana

Hm, forgot to ask, but what version are you using? If not 22.0.0 can you try upgrading to that?

Thanks,
Steven

The output shown above was calculated using 21.0.1. But I have also checked with version 22.0 (on our cluster). Unfortunately, the problem remained.

Out of curiosity, have you tried the fieldmapless SDC option?

Please excuse the late reply. Yes we also tried to run it without the field maps to check whether the problem indeed can be attributed to the field maps. And the fixed vs moving images look better without the fmap correction.

Got it, and just to be clear are you saying you tried no SDC method, or the fieldmap-less SDC method (syn-SDC)?

Good question, I did not know that there is a difference. SDC: none, simply by not including the fmap folder

Can you try the syn-SDC method and see if that works?

Sure! Do you mean using --use-syn-sdc? And I suppose I should remove the IntendedFor from my fmaps (or the whole folder) or will anything related to fmaps be ignored anyway?

You do not need to touch the json files. You can add the ignore fieldmaps argument, but I think they will be ignored by default if you use syn.

Some time ago I reported a very similar issue (still not resolved): Wrong SDC based on fieldmaps estimated by phase-differences (but OK based on PEPOLAR) . Maybe reverting to PEPOLAR-based correction will be a solution in your case as well.