FMRIPREP: N4BiasFieldCorrection fails

fmriprep
#1

Dear fmripreppers,

I am experiencing weird EPI to T1 registrations for some FMRI sessions:


(this ‘was’ a whole brain scan of a healthy subject)

After going through the working directory, I think this comes from N4BiasFieldCorrection, because after this stage the output looks like the image above. Furthermore, calling N4BiasFieldCorrection with the fmriprep arguments and additionally –shrinkage-factor 3 seems to solve the problem.

This only happens for some of the MRI sessions, while others work fine.

I uploaded the command.txt and the input and output files for the N4BiasFieldCorrection call here.

I am happy to provide more information if needed,
onu

EDIT: I am using fmriprep version v1.3.1 with call
singularity run -B /data/pt_01994,/data/pt_01756/tmp/fmriprep_wd:/wd
/data/pt_01994/fmriprep-latest.simg
/data/pt_01994/bids
/data/pt_01994/fmriprep/output/
–fs-license-file /data/pt_01994/fmriprep/license.txt
participant --participant-label 01 02 03 04
–t2s-coreg
–output-space T1w template
–nthreads 10
-w /wda/
–fs-no-reconall

0 Likes

#2

Does the dataset have Single Band references? (sbref)

0 Likes

#3

Hello Oscar,

no we did not save sbrefs.
In the meantime I reran fmriprep for the subjects that had failed in the first go with –force-bbr and this ‘solved’ the problem.

0 Likes

#4

Glad you got that sorted out. Could you share the output log from fMRIPrep for the failing case? we would be interested in investigating the original cause of failure.

0 Likes

#5

There was no error detected, so there is no log directory in the fmriprep/sub-04 folder.
Or do you refer to the .html report?

I could ralso erun fmriprep with the –verbose flag if that helps.

0 Likes

#6

Yes, I meant the output from fMRIPrep. I think the argument -vvv will give us enough verbosity. Thanks!

0 Likes